Hi all,

Like the title explains.
I created an Form with input fields in a module with Liverpool as theme.
All of the fields are edible but still they all get the following CSS class from: Form.css
.Form input.ReadOnly, .Form textarea.ReadOnly, .Form select.ReadOnly {
    background: #fafafa none repeat scroll 0 0;
    color: #333;
    font-size: 16px;
}

Why does it get this class?
I solved the problem by overwriting the unneeded class elements but this is not good coding off course.

Thanks all!
 
Hi Martijin,

Check the properties of the Form. It has a enabled property that overrides the children inputs.


Regards,
João Rosado
Hi João,

The form also has Enable = True.
In the application the inputs are also editable, just discovered that when I click in one of the input the Read-only class disappears.

Regards,
Martijn
Yeah, I noticed that last week when I was doing some styling. A bit odd to call something "ReadOnly" when it's not read only...
What is the resolution to fix this? We are having this exact same problem on quite a few different datetime text input fields, and it makes it impossible to edit the input, or even close the datetime silk widget.

From: Theme.Patterns_SilkUI:
input[readonly="readonly"],
input[disabled="disabled"],
select[disabled="disabled"] {
    background-image: none;
    color: #999;
    cursor: text;
}

And from the HTML:
<input name="LiverpoolTheme_wt8$block$wtMainContent$wt5$wtDateTimeStartInput" type="text" value="04-01-2015 00:00:00" maxlength="50" id="LiverpoolTheme_wt8_block_wtMainContent_wt5_wtDateTimeStartInput" tabindex="14" class="ThemeGrid_Width5" onkeydown="return OsEnterKey('LiverpoolTheme_wt8_block_wtMainContent_wt5_wt18', arguments[0] || window.event)" style="margin-left: 10px; background: none;" readonly="readonly" placeholder="MM-DD-YYYY HH:mm:SS">


For some reason readonly="readonly" which is activating the CSS, but the text box in Service Studio is set to Enabled.
 
Is this still happening in the latest instalment of the platform?
No matter what I change in the CSS, that "readonly="readonly"" is ALWAYS set, breaking the input.....

Hi all,


This is still happening in 11 version, both inputs, read only or not, get the same class.
Do you have any solution?

Hi,

I'm facing the same problem on Service Studio 11 Traditional Web, I removed the Style Class "form" from the form component, after that, some pencil icons apeared under the inputs, so I had to define this in the CSS:

span.FormEditPencil{
    display:none;
}

 and it was solved. I don't know any other consequences of it, but until now its ok!

If any of you know problems in doing it, i'd like to know.

Thks