Crystal Reports Developer Version for Visual Studio using Outsystems SOAP action

Crystal Reports Developer Version for Visual Studio using Outsystems SOAP action

  
A while ago I tried using an older version of Crystal Reports (2008) and got great help here on the forum to determine that that version didn't support a web services data source in a way that could be used to call an Outsystems SOAP action.  I was able to download a trail version of Crystal Reports 2013 and it worked successfully.

My trial has long since run out and at the demo phase I am in I cannot buy the license but did find something that I should be able to use called the Crystal Reports Developer Version.  This free product (http://www.sap.com/solution/sme/software/analytics/crystal-visual-studio/index.html) integrates with Visual Studio to create reports.  I successfully pointed it at the WSDL for my Outsystems SOAP web service and it correctly recognized the actions and parameters as a data source.  I run into a problem when I try and run the report in that it asks for login credentials, which I supply (including admin credentials) and it always says login failed.  How can I determine what is going wrong?

Curt
Hi Curt,

Where's the problem, with the free product or with the platform? At what point does it ask for credentials? Etc.
Kilian,

As mentioned above all the development is fine, I can create a datasource with the WSDL and I can create a report using that datasource.  The request for login happens when I run the report.  The attached document shows what happens.  Since I'm not doing anything intentionally to secure the service I'm using I was surprised it was asking me to logon.  I was further surprised when I entered the admin username and password (many times now) and it too is rejected.  I appreciate any thoughts you might have.

Curt
That's indeed odd. Does it signify anything that the "Database" field is empty? Can it even find the right database?
No other information other than what I posted previously.  I'll do some more digging.  Since I haven't done much with SOAP I was hoping someone could point me at something obvious.  Oh well!

Thanks for your help,
Curt