Parameters for using Links,images in Email Body in RichMail

Parameters for using Links,images in Email Body in RichMail

  
The body of the Email contents images, links, rich data. What should be the parameters like ContentType and Charset for such type of email body?
The email body is in HTML form.

Can anyone please help me with this?
As a generic response I'dd say that Content-Type: text/html; charset=utf-8 would workd just fine.

Hope it helps.

By the way, where are you seing this parameters in the OutSystems plaform?
Hello,
These are the parameters for RichMail widget.

I tried using Content-Type: text/html; charset=utf-8, the mail comes in encoded form. For example I received the mail with content below:

This is a multi-part message in MIME format. ------=_NextPart_:_3259167f-1783-48c9-a081-5ce118ae5442 Content-Type: multipart/related; boundary="----=_NextPart_:_bd71659b-b98a-4b09-a518-6f955ba84f85" ------=_NextPart_:_bd71659b-b98a-4b09-a518-6f955ba84f85 Content-Type: multipart/alternative; boundary="----=_NextPart_:_fe881c55-b58e-4d45-b13d-6390533866c3" ------=_NextPart_:_fe881c55-b58e-4d45-b13d-6390533866c3 Content-Type: text/plain; charset="iso-8859-1" Content-Transfer-Encoding: base64 ------=_NextPart_:_fe881c55-b58e-4d45-b13d-6390533866c3 Content-Type: text/html; charset="iso-8859-1" Content-Transfer-Encoding: base64 PCFET0NUWVBFIGh0bWw+DQo8aHRtbCB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMTk5OS94aHRt bCIgPg0KICA8aGVhZD48dGl0bGU+DQoJRW1haWxDb250ZW50DQo8L3RpdGxlPg0KICAgIA0KICAg IDxtZXRhIGh0dHAtZXF1aXY9IkNvbnRlbnQtU2NyaXB0LVR5cGUiIGNvbnRlbnQ9InRleHQvamF2 YXNjcmlwdCIgLz48bWV0YSBodHRwLWVxdWl2PSJDb250ZW50LVN0eWxlLVR5cGUiIGNvbnRlbnQ9 InRleHQvY3NzIiAvPgo8c3R5bGU+DQouT1NGaWxsUGFyZW50IHsgDQogZGlzcGxheTogYmxvY2s7 DQogd2lkdGg6IDEwMCU7DQp9DQp0YWJsZS5PU0ZpbGxQYXJlbnQgew0KIGRpc3BsYXk6IHRhYmxl 
So you're using the RichMailSend action.

AFAIK that message only appears when the email client is not capable of interpret the mail content properly.

That might happen for one of two reasons:
  • Your email cliente does not support. I'dd say that's highly unlikelly, but you can test that but sending the email fto a different address and try to open it on gmail for example.
  • The email format is incorrect, in what case I'dd start by creating a simple email and add things progressivelly to see where it breaks.

By the way, why are you using the RichMail extension? The Email in service studio would allow you to use email in a much more simple way.
Hi Carlos, We had a requirement of using different SMTP servers for different clients i.e multitenant. Email in service studio works for a given SMTP server in service center, we wanted it configurable.

And thank you, I was able to resolve the issue. The email body had formatting errors.
Great. 
I'm glad everything is working now.