Upgrade error message.

Upgrade error message.

  
Hello.
 
After upgrading to Development Environment 9.1 I´m following the tutorial with everynthing running well, but I see this message:
"Incomplete Upgrade Module 'Charts' was deployed with an old OutSystems Platform Server version. Please publish 'Charts' to fix it."
Another to 'users'
Another one to 'RichWidgets'
 
How can I fix it?

Hi Carlos,

It seems that you didn't publish the "System Components.osp" after the environment upgrade.

Please confirm if you executed sucessfully the following CheckList step :

Install System Components:
  • Log in to Service Center using your administrator credentials (http://<yourserver>/ServiceCenter)
  • Go to the solutions screen (Factory -> Solutions)
  • Click Upload and Publish a Solution and select the System_Components.osp file in the Platform Server installation directory (e.g.: C:\Program Files\OutSystems\Platform Server\)
  • Click 1-Click Publish, or Prepare Publish if you have 2-Stage deployment active.


Hope it helps you!
Best Regards.

Daniel Martins

Olá, Daniel.
Obrigado pela sua resposta.

Não encontro essa pasta .
Só tenho nesta diretoria (C:\Program Files\OutSystems\) o seguinte:

  • Installer
  • Development Environment 9.1
  • Development Environment 9.0
Fiz uma busca e não encontro nada c/ o nome "System_Components.osp" ou "Platform Server".
 
Olá Carlos,

Terá, por acaso, instalado o Platform Server noutra drive? Ou o seu servidor é remoto? Nesse caso terá antes de aceder via Remote Desktop (se for ambiente Windows) e procurar a drive e pasta correctas. Tipicamente, a plataforma é instalada em \Program Files\OutSystems\Platform Server\ e aí poderá encontrar o arquivo "System_Components.osp"

Cumprimentos,
Pedro
Obrigado Pedro pela resposta.

A instalação das 2 versões foi feita na Drive C. Faço a busca em todo PC e não aparece nem a pasta nem o ficheiro osp.

Estou a usar neste momento o Development Environment 9.1 sem problema pois já completei a primeira parte do tutorial. Não deveria estar aqui em C:\Program Files\OutSystems\Development Environment 9.1?

Este é o seu conteúdo inicial:  
  C:\Program Files\OutSystems\Development Environment 9.1\uninst.exe
  C:\Program Files\OutSystems\Development Environment 9.1\OutSystems End-Customer License Agreement.rtf
  C:\Program Files\OutSystems\Development Environment 9.1\Service Studio
  C:\Program Files\OutSystems\Development Environment 9.1\Integration Studio

Envio em anexo uma lista de todos os ficheiros Outsystems no meu sistema.
Boas

Estou a ter o mesmo problema, para além que depois nao consegue fazer o "deploying"
Tirei uma print que pode ajudar a perceber melhor o problema:
https://i.imgur.com/A06PbwI.png
@Carlos, @João: obrigado pelo vosso feedback mais detalhado. Pelo que entendi, estão a usar a Personal Environment, certo? Nesse caso, não há como instalarem os System Components, pois o servidor da plataforma (Platform Server) da Personal Environment é providenciada e gerida pela própria OutSystems - mais detalhes em OutSystems Platform Personal Environment FAQ. Contactei já a equipa OutSystems Success Team <success@outsystems.com>, que irá avaliar a vossa situação.

Até breve,
Pedro
Boa noite,

Estou a ter exatamente o mesmo problema. Comecei o curso foudation hoje e também me surgem os mesmos erros.


Ricardo
Boas

Fiz tudo igual e ao que parece o erro desapareceu e já consigo trabalhar bem. 

Obrigado
Boa noite,

Também tenho o mesmo problema apontado acima..
Agradecia que disponibilizassem uma solução para poder realizar o tutorial..

Obrigado.
Miguel
You can find related information to this issue on our Support Knowledge Base.

In a nutshell - it is harmless, but there is an easy way to get rid of it. Let us know if it works (it should!)
Should I send an email to out systems support too?
Rushi, no need. If you are experiencing this issue just follow the instructions in the article I shared and you will be fine.