Outsystems Now login not skipped if no default app is set

Outsystems Now login not skipped if no default app is set

  
Hi,
I'm tryng to customise OutSystems Now iOS app as instructred on video https://www.youtube.com/watch?v=wja19rPqDnI
All working fine except that if I dont specify default app URL and have only one app available for OSNow so it loads by default the login splash screen is still appears before loading the app itself.
Hi Mykola,

To be honest I've never tried that so I'm not even sure what happens. Can you please better explain:
  1. What is exactly happening? (screenshots helps!)
     
  2. Is there a reason why you're not specifying the link of the application?
Cheers,
RG
Hi Rúben,
The reason for not input app link is that in offline mode it fails(( If I have only one app (for example "Inspections") activated for OSNow in OutSystemsNowService and do NOT input link it works as expected in offline mode, but if I specify link then I have an error.

So basically I need to have 1 app in OSNow that will support offline mode and do not show any additional login screens. Also I've noticed that if I DO input app link my app will login the admin user (account that is used to access the environment) on launch instead of previous session or no user as it happens when do NOT input app link or using app in a browser.

I would appreciate any help regarding this issues.

Thank you,
Nick
Hi Mykola,

Sorry for the late reply.
I'm not sure if I'm understanding the use case that you want to implement on OSNow.
Just to make things clearer, do you want to create and app that works offline and dont have any other native screens (no environment selector screen and no login screen) than the webview screen, right?

Cheers,
Luís Silva


Mykola Tkachenko wrote:
Hi Rúben,
The reason for not input app link is that in offline mode it fails(( If I have only one app (for example "Inspections") activated for OSNow in OutSystemsNowService and do NOT input link it works as expected in offline mode, but if I specify link then I have an error.

So basically I need to have 1 app in OSNow that will support offline mode and do not show any additional login screens. Also I've noticed that if I DO input app link my app will login the admin user (account that is used to access the environment) on launch instead of previous session or no user as it happens when do NOT input app link or using app in a browser.

I would appreciate any help regarding this issues.

Thank you,
Nick
 Hi Nick,

I'm experiencing the same problem. did you manage to resolve it? and if you did, how did you resolve?