[FeedbackMessage++] Timeout not working when triggered from popup

[FeedbackMessage++] Timeout not working when triggered from popup

  
Forge Component
(7)
Published on 19 May by André Siébra
7 votes
Published on 19 May by André Siébra
Hi all!

I used this feedback on a project I was working on and it was working perfectly until I placed it in a popup screen action. Basically the timeout period entered is ignored.
I don't know if perhaps it has anything to do with a Popup_Notify within the flow.

Can anyone help out?
Thanks!

Hi Sónia!

Thanks for the feedback. I'll check it out this. 

Cheers,
Hi,

It's happening the same thing to me and i'm using a Popup_Notify too.

Cheers
Thanks Gustavo.

I'm very busy these days, but I have plans to provide an update with this fix next week.

I hope get it soon :)


Hi guys,

The new version of the component with this fix is already available. Please, check if everything is going fine now.

Sorry for the late.

Cheers


I'm using this all my popups but it seems my popups are always taking close to 15 seconds to close - no matter what I set the Timeout value to be.

It also won't work close out the message at all if the MessageType is Error.

Platform Version 9.1.501 - PAAS

Has anyone else experienced this behavior?

Cory

Hi Cory,

Idk.. maybe you are not placing the widget correctly... Can you share the oml? 

I can't really share the oml - I did more testing and the only place I seem to be experiencing the problem is when I trigger a message from a webblock in a popup and then close the popup.  The message is created from the webblock.

I've attached a screen shot of the save action of the webblock that is used in the popup where the message is created.  Will that be helpful?


Cory

Yeah, it helps. With this details I have a scenario to test.

I'll check this out as soon as possible.

While this is not fixed, you can try a workaround, placing the feedback message action in the notify action of the popup instead of the Save action of the webblock. 



The workaround works - I pass the feedback message in the Popup_Editor_Notify action and then in the webblock that called the popup I use the NotifyGetMessage and place the message in the Feedback.

Thanks!

I love this component - thank you so much!  

I did find one other place where it doesn't seem to work when a normal Feedback Message will.  If you are ending your flow to an External URL, the Feedback Message won't display at all - but if I change it to a normal Rich Widgets Feedback Message, it displays fine.

Cory

Cory Creamer wrote:

I love this component - thank you so much!  

I did find one other place where it doesn't seem to work when a normal Feedback Message will.  If you are ending your flow to an External URL, the Feedback Message won't display at all - but if I change it to a normal Rich Widgets Feedback Message, it displays fine.

Cory

Hi Cory!

Good to know you're enjoying it :)

Check this discussion. I think the problem you've mentioned above is related with it. 

Thanks for the feedback!