GMAIL SMTP not working in Personal Environment

GMAIL SMTP not working in Personal Environment

  
Folks,
I am 3 weeks into evaluating OutSystems in a Personal Environment. I can't get it to connect to smtp.gmail.com

I tried using ports 465, 587, and 25 but get the error in the attached screenshot.
I am positive my login ID/PWD is correct - re-entered multiple times.

Who can help??

Hi Bruce,

Did you check the sticky topic on this section of the forum?
http://www.outsystems.com/forums/discussion/11645/how-to-send-emails-from-your-personal-environment/

Anyway, if you want to use gmail, short story is that you need to port 587 but you will need to go to your google account and configure it correctly for an external app to use the smtp service in your behalf.

The error that google sends is very missleading. Is not the user/password that is wrong, is just that you shouldn't use your normal username/password on services.
I got my account locked once because it got suspected that I was accessing from both my country and from Ireland (the cloud server) at the same time.

Try googling for: google mail 535 5.7.8
You will find a lot of links on how to fix it, but the recommendation is as the topic I link said, to avoid google smtp.


Regards,
João Rosado
João Rosado wrote:
Hi Bruce,

Did you check the sticky topic on this section of the forum?
http://www.outsystems.com/forums/discussion/11645/how-to-send-emails-from-your-personal-environment/

Anyway, if you want to use gmail, short story is that you need to port 587 but you will need to go to your google account and configure it correctly for an external app to use the smtp service in your behalf.

The error that google sends is very missleading. Is not the user/password that is wrong, is just that you shouldn't use your normal username/password on services.
I got my account locked once because it got suspected that I was accessing from both my country and from Ireland (the cloud server) at the same time.

Try googling for: google mail 535 5.7.8
You will find a lot of links on how to fix it, but the recommendation is as the topic I link said, to avoid google smtp.


Regards,
João Rosado
 Yup, I saw that from back in 2014 - so - I was hoping it was just "an old issue".
I am using Google Apps for Business so my company email domain is managed by Google.

Thus, I am really concerned about sending email from an SMTP server that has a domain other than my company domain. You see, often, using a 3rd-party SMTP to "send as me" causes most email clients/services to think it is SPAM.

In my case, using Mandrill's SMTP (for example) but listing the mail as "from xyz@redipay.team" will make it look like a spoofed email and thus SPAM. 
Maybe I am missing a way around this "potential SPAM" issue ... but, do you see what I mean?

So ... currently I am reading in my Google admin account about "SMTP Relay" feature that I might work for me.

 
I can guarantee you that you can set it up correctly with some work.

We got internal servers using google smtp (as our OutSystems mail also uses Google Apps for Business) but sincerely they changed the config pages in the google side so much that I have no idea where to configure it.

Please share your findings and progress here so others can also know how to set it up if needed :)

Regards,
João Rosado
Will do - I spent about 20 minutes on the SMTP Relay side and got confused on if / how it might meet my need.
I was concerned without knowing the purpose of Relay I could risk our company email service!

So, I have to pause it for now - I am going to use another SMTP for now --- BUT --- I definately have to figure this out BEFORE ... I can go live.