Decimal separator



I would like to solve the following issue.

I have an input field where by default we have a value with the decimal separator as a DOT (.), but I want to enable the end user to set a "comma" as a decimal separator.  Next to this input field there is a small box that makes some calculus (like 0.14*10 =1.4 , now I want the possibility to do the calculation for 0,14*10=1,4 but it delivers always zero...). I cannot set the DecimalSeparator site property with two possible values, of course. I have tried to use the REGEX SEARCH to seek for comma, which works fine. then I used an assign and tried to use the formatdecimal function...


but this did not work... I suppose that the conversion TextToDecimal the platform will use the dot as decimal separator.... Any hints to solve this? Thanks!


Solved with the Regex Replace, but this only resulted to substitute the comma for dot... and making the calculations accordingly. For example:

0,25*10 will deliver 2.5 and not 2,5 (desired).

It is not perfect but, at least, delivers the right result. Any suggestions would be welcome.