Application cannotbe safely installed in your environment.

Application cannotbe safely installed in your environment.

  

When I tried to install an application (built by myself) through the Forge, I encountered the following warning/error message:

Application cannot be safely installed in your environment.

(…)

PokeBrainTest is not compatible with your platform version.

Force Install works fine and there are no problems with the application.

What can I check to avoid the above warning/error mesage? As far as I know I am using the same Platform version and for sure using the exact same version of Service Studio (10.0.105.0).

Best regards,

Peter Nijhuis.

Hey!

Are you still having this problem, or have you been able to install the component?

Cheers,

Carla Sofia

Community Manager

Hi Carla,

Thanks for your response!

The problem still exists. When I install the application in my "peternijhuis.outsystemscloud.com" environment, it comes up with the error mentioned above. Then I hit the "Force Install" button and the application installs and runs without problems. It's about the application PokeBrainTest in the Forge. This application has a dependency with PokeBrainCore.

Hopefully you can find out what's happening.

Thanks in advance!

Best Regards,

Peter.

Carla Sofia Teixeira wrote:

Hey!

Are you still having this problem, or have you been able to install the component?

Cheers,

Carla Sofia

Community Manager



Hello Carla Sofia,

(Hope you will read this)

I have good news and I have bad news. The good news is I found something. I have two environments, let's call them Env01 and Env02. I have an application divided in core and presentation, let's call them AppCore and AppWeb. AppCore has a lot of REST webservices. Two webpages in AppWeb CONSUME these webservices. There things went wrong. When I created AppWeb in the Env01 environment everything was fine. However, when I published my application to the Forge and loaded it into Env02, the webservice to be consumed still resided in Env01! 

This gave very strange results, e.g. when I was debugging in Env01, Appweb running in Env02 would hang because the called webservice referred to Env01.

So I thought this would be the problem why OutSystems keeps telling me that it's unsafe to install the application. However, (and that's the bad news) I STILL get this message.

My question to you is: "If OutSystems knows there is something wrong, why doesn't it tell me WHAT it thinks might be wrong?"

I'm very curious, because things like this hold me back moving to a cloud development environment for real production systems.

Best Regards,

Peter.

Hello Peter,

I tried installing the PokeBrainCore application, and in fact it issues the "not safe to install" message, but it tells me the reason why: The version of SilkUI used to build the application is different from the one I have installed. Don't you get a similar message explaining what's going on?

The WebServices problem is a bit different. It makes sense that we keep the original URL of the service (usually that's what you want) but you can work around it in 2 ways. One of them is to set the URL to "localhost", if you assume the Web Services will always be installed in the same environment that runs the front-end. The other option is to set the effective URL for the Web Service in Service Center. On the eSpace that consumes the web services, go to the "Integration" tab, click the web service you want to configure and set the "effective URL".

Hope this helps,
Rodrigo

Hello Rodrigo,

Thanks for your complete answer. Especially the part of how to consume a webservice in different OutSystems environments. I have worked around it by creating a Server Action, but it's good to know that there is this "effective URL" option.

The issue with SilkUI worries me. In Platorm version 9 I once installed the Dublin theme and I saw it appear in my "Applications in Development". After the upgrade to version 10 I don't see Dublin and neither SilkUI. I never installed it again. In my "peternijhuis" environment I removed all applications. Then I tried to install SilkUI/Dublin, but it tells me: "This project cannot be installed because you alread have a customized version running in your environment."

How can I resolve this? By the way, the warning that I receive doesn't say when installing PokeBrainTest nothing about SilkUI, see attachment. In both "peternijhuis" and "casaspider" I do not see SilkUI nor Dublin appearing in "Applications in Development".

I think we are closer to the solution, but I still can't mark your answer as Solution... :-)

Thanks in advance and best regards,

Peter.

Hello,

It looks like you did some changes to Dublin and/or Silk, is that right?

By downloading Silk Web and Templates from Forge and installing them, choosing "Force Install", you should be able to remove the "custom version" problems, could you try that?

This would make your installed version not "custom" again, and remove  the warning.

If that solution fails, you are able to remove  the outdated components from Service Center and install again from Forge.

Let us know if this helps, my regards

Hello Dinis,

I did not (intentionally) change anything in Dublin and/or Silk.

Once I made some reference to ListAllAppend, which had disappeared for some reason. That's the only "strange" thing I noticed. I just installed the latest version of the Dublin theme (3.0.x), but this did not help. 

I do not see neither SilkUI nor Dublin in my "Applications in Development" as I used to when using Platform version 9. I have de-installed everything in the "peternijhuis" environment, but when I install PokeBrainTest the error comes back. 

In Environment Management I see that I installed Template Dublin and DublinTheme just a few minutes ago. I have no clue how to uninstall them, if I wished. 

What can I do to debug this issue?

Thanks in advance and best regards,

Peter.

Hello!

Silk and Silk Templates are hidden by design in Service Studio 10 to prevent users from changing core components of the Framework that would add problems later on. You are still able to remove them via Service Center.

I did install PokeBrainTest and I got the same warning as you did. After opening the application, I noticed that PokeBrainTest does not use Silk at all, it is built with London Template. This means that Dublin is not used at all, so it can't be a problem.

It seems that your application was changed on your environment, that's why the Forge version is not compatible anymore. So, you probably want to force install the Forge version or update the Forge version with the one on your server.

Let me know if this helps, cheers

Hi Dinis,

I'm not sure if I understand what you suggest me to do.

What I did now is this: 

I downloaded the PokeBrainTest in my "peternijhuis" environment, the one that has been installed from the Forge using Force Install.
I uploaded this file to the Forge.
I deleted PokeBrainTest in my development environment (casaspider).
Then I installed PokeBrainTest from the Forge.

Unfortunately it gives me the same error and I have to Force Install it.

Meanwhile I have created a new (mobile) application PokeBrain. This one installs without problemsn. However, not being able to resolve the Force Install issue worries me, because exactly these kind of thins make people afraid to be depending on "The Cloud".

Nevertheless, thank you for your attempt!

Best Regards,

Peter.