How to remove users added from Sales downloaded from Forge

How to remove users added from Sales downloaded from Forge

  

I removed the sales and now its sample users are in my environment. How I remove them ?


Thanks in advance for any answer

Luck

Hi,

You can remove them manually through the "Users" app (<yourenvironment>.outsystemscloud.com/Users).

If there are too many, you could build a simple app that retrieves the list of users to remove and iterates through it, calling the "DeleteUser" action for each one.

Hi Aurelio,

    I didn´t find the option to delete inside de Users app. I tried the delete option using the Multitenant app but I received an error message. I tried to remove the deleted table from my environment using the DBCleaner but without success. I am attaching the steps I did. Do you know how to fix this ?

Thanks for your previous reply

Luck

Hi Luciano,

The delete option is available in the right side of the screen when you click "Edit this User".

This error means that there are records in a different table (apparently it's a table named "Employee") that reference the user you're trying to delete, which prevents you from deleting it. You're gonna have to delete all records that reference the user before being able to delete it.

The second error is caused by a similar situation: there are other tables that reference the "Employee" table through a foreign key, which prevents you from droping it.

Hi Aurelio,

   that is the point. How to access a table that is deleted and is hard to understand how a deleted table is affecting an user... The unique way I have to access to a delete table is via DBCleaner. Do you know how to access a table deleted and to clean all registers ?

You will see in the last picture that I have only 3 tables from Employees eSpace that I cannot clean (OrganizationUnit, OrganizationUnitType and Employee).

Hi Luciano,

Those tables were marked as deleted, but weren't actually removed from the database yet. So all of the Referential Integrity rules are still in place.

When you install the Sales app, a bunch of other apps are also installed (CRM Services, Employee Services, etc). Is it possible that you forgot to remove one of those apps? The idea here is to try to identify the tables that are referencing the ones you can't remove using DBCleaner.