[CameraPreview Plugin] Error: CameraPreview is not defined

Forge Component
(3)
Published on 14 Aug by Hugo 
3 votes
Published on 14 Aug by Hugo 

Hi,

i tried to use the CameraPreview Plugin, but in Example-App and in my own App i get the error "CameraPreview is not defined" after starting "StartCameraPreview". Any ideas what goes wrong?

I tried on IPad and Outsystems platform 10.0.210.0


Jens

Hello Jens,

I just tested the plugin using the sample app and everything appears to be ok...

Just to be sure, did you create a native application and installed it on your device in order to use the plugin? You need to create a native app for the plugin to work...

If you did create the native app, and it still doesn't work, might be an issue plugins had in some versions of the platform... To fix, open the CameraPreviewPlugin module, go to the module properties and open the Extensibility Configurations. Add an enter in the end of the JSON. Next, open the module that is using the plugin, refresh the references and publish the module again. A new version of the native app will automatically be built. Install on your device and everything should work.

Best of luck!
R

Hi R,

thanks for your answer. I published my App with outsystems, but until now not as an native app. If this is the reason, how can i test it, without creating a native app? Any chance?

Solution

Sorry, you'll need to create the native app in order to test the plugin.... Part of the plugin is native code...

Solution

Rodrigo Coutinho wrote:

Sorry, you'll need to create the native app in order to test the plugin.... Part of the plugin is native code...

Hello, i tried and i founded the next error "Duplicate elements declared" Outsystem 11 when i generate android native app.


Regards!


Hi Luis,

Do you get this error while generating the your app or the demo app?

I just tested the plugin using the sample app and everything appears to be ok...


Best regards,

Daniel Martins

Daniel Martins wrote:


Hi Luis,

Do you get this error while generating the your app or the demo app?

I just tested the plugin using the sample app and everything appears to be ok...


Best regards,

Daniel Martins

Hello, i solved the problem, the real problem was that i have  previewsly installed the "barcode plugin", then uninstalled (Barcode plugin) and i could finally generate the app for install, but i lost the functionality of QR.


Regards!


Hi Luís,

Thank you for reporting the issue.

Hugo just uploaded a new version (3.0.3) that solves that issue, was occurring with Android devices when CameraPreview plugin as being used together with BarCode plugin or other plugin that required Camera functionality.

For future reference:

Thank you Hugo and OS Demo team.