Cannot connect to local MySQL database

I need to create a database connection to my local mysql database. When I try (from Administration - Database connections) I get this error:

"Connection String test failed: Unable to connect to any of the specified MySQL hosts." What I need to correctly connect to my local server? Other details:

- Server is up and running

- I selected MySQL in DBMS

- Inserted in Server. Also tried localhost

- Inserted my schema name

- Inserted the username (with all privileges granted in server options)

- Inserted the user password

Tried both basic and advanced configuration. I inserted j"dbc:mysql://" as connection string parameters and I get "Connection String test failed: Keyword not supported.Parameter name: mysql://"

Can someone help me please? I'll really appreciate a specific answer ( no link to video tutorials please) Thank you for your help and time

First of all, where is your Outsystems Platform Server?

All database connections will be done by Platform Server, not your Service Studio.

If you're using Outsystems on Personal Cloud Server, then your MySQL server should be on Public Internet IP (or routed through public ip) and accessible through internet (make note of security etc).

If you're using on-premise Platform Server, can your platform server connect to your MySQL?

You cannot use localhost or unless your Outsystems platform server and your MySQL server is on the same machine.

Hope you get it...

Hi, thank you for your help. I'm using the Personal Cloud Server. I set the MySQL user accordingly, but nothing changed ( now I used my external IP address instead of localhost also). I will try installing the Platform Server and using it

EDIT: Still not able to correct it, the Server Platform seems to be not useful.  I just need to access the MySQL server from the Outsystems application, configuring a connection.


For personal cloud server, if you have external ip (or public ip) for your MySQL server, then try to connect from other computer using only internet connection.

If you have installed on-premised / on-location Platform Server, then from the server machine itself try to ping to your MySQL server.

In my experience, it usually only a matter of network connectivity.

Please check also your firewall...