Cannot Change Name of Button Group + Unexpected Button Value AutoCompete Options


I'm so sorry, this must be the most newbie question ever asked. I have managed to get stuck while following the learning materials! Have tried backing up and repeating steps, as I'm clearly doing something silly.

I'm on the List & Details Screen Exercise of the To Do app. On page 19.

1) I am putting a Button Group into a Container which is within a List. The guide says to change the name, but it seems to be locked, I can't change its name. First time I've had that problem. I guess I am causing that somehow, perhaps by getting it in the wrong place, but have quadruple checked I am following the guide.

2) If I ignore that and leave the default name and move on I am supposed to set the variable to something using a dropdown but have to select from a tree structure. No problem, but I mention just in case that gives away what silly thing I am doing. So I find the right thing from the tree of vars.

3) I then change the text of the three button group buttons, that goes okay.

4) A possible issue crops up (sort of, probably me getting it wrong), I have to choose a Value for the three buttons of 'Low', 'Medium' and 'High', these are supposed to be presented as options from a dropdown but I have to click on an ellipsis and chose from an expression editor. I have tried just typing the vars as text, wrapping in quotes, but I think I am probably supposed to be putting something more sophisticated. But maybe not.

Apologies again for posting on a forum to ask how to follow a guide - feel free to ignore! I'll probably figure it out, the guides have been flawless so far and very useful.



Hi Danny,

First of all, don't worry about asking "newbie" questions. We were all beginners once, and now we're all here to learn and to help each other. :)

1 - That's strange. You should be allowed to change the ButtonGroup's name. I remember once running into a similar issue that appeared to be a bug: after dropping a new widget in my screen, all of its properties appeared greyed out, which prevented me from changing them. Maybe that's what happened to you. The workaround is to open a different screen from your UI Flow and then go back to the previous screen.

4 - In this particular case, the values of the buttons are records in the "Priority" static entity. The image bellow shows how to specify these values in the expression editor:

Let me know if you need any additional help.


Hi - thanks!

I think you were right about the glitch. I actually just reopened the studio to try what you suggested and the problem is gone - and infact all the enusing wierdness were gone - I retried the other steps and they all worked perfectly.

I wouldn't entirely dismiss the idea that I was just being an idiot in some way when I first did this the other day though!

Thanks anyway!

Oh and thanks for clarifying about the values being assigned to the buttons (point 4). I am a bit sleep deprived and really didn't get what type they were. I mean it was obvious in an analogous sense, but not any real understanding. I blame intrusive midwives telling my wife our baby is starving to death (because they have no concept of variance and trend rates and the fact that you can learn NOTHING from a pair of daily weights of a newborn baby as they vary with every feed by significantly more than their daily growth rate.) and the zero sleep I have had for weeks. Anyway, I digress very slightly!

Your explanation of which values are being assigned makes perfect sense!