OneSignal push notifications

Hi guys,

I'm trying to setup OneSignal to send push notifications on my mobile app, for that I followed this tutorial:

But when I try to test it (with a button to activate the notification and a input with the message to show up), I keep getting the error message: "400 bad request"

Can anyone help me figure out what I might be doing wrong?

Hi João,

I didn't quite understand your app flow. You have a button to activate the notification? Is it to register the device? Or to send the notification? Furthermore, when are you getting the "400 bad request" error message? What action did you call?

Best regards,

Ricardo Alves

The button is to send the notification, and that's when I get the error message. I'm calling the "Notify" client action.

One thing I haven't noticed before (because i forgot to setup the error message) was that it fails to register the user both with the "RegisterWithUser" and the "Register" client actions on the OneSignalPlugin, could this be a problem with the AppId from OneSignal? 

Hi again João,

If you've set up your account on OneSignal and properly configured your app, it should work.

Please check that you are using the correct keys and ids. Keep in mind that you'll have to setup your OneSignal account first, with your Android or Apple keys, and, when using the OneSignal API, you'll have to use your OneSignal keys. Please make sure you are using the right keys, at the right action.

Let me know if the problem persists.

Ricardo Alves

Hi Ricardo, 

I still can't get it to work, I've tried with booth Pushwoosh and OneSignal but they both fail on register and I'm pretty sure i'm using all the right settings. The only thing I'm not sure of is the certificate generation, but I no longer have a mac available to redo the certificate and test it again.

Don't know if it helps but on Pushwoosh the error message I was getting was: 

"Pushwoosh plugin is not present or not loaded"

And on OneSignal I was getting the error: 

"Plugin is not loaded."

edit: Upon further investigation using Pushwoosh I found out that the problem is that I'm not getting back a token from Apple or Google when using the RegisterUser with the App Code generated for my application

Hi João,

How are you testing it? Are you using a web browser? Or using OutSystems Now? 

Hi Ricardo,

I've tested it with both outsystems now and the generated app.

Any clue what might be happening?

Hi again,

The issue you're having means that the plugin has not been included in the application. OutSystems Now has no support for the PushWoosh plugin. The same is applicable when you try to use it on a web browser.

In order to properly test the plugin, you need to generate the app, and install it on a real device.

Let me know if you're still having issues.

I've tried that approach. I tried to do it for both iOS and Android and they both failed to register the device with pushwoosh.

Just wondering if you managed to resolve this issue.  I'm experiencing the exact same behaviour.

I also followed the same documentation, and am not getting any notifications. Neither am I getting any errors. I have double checked all the keys and ids, but everything seems in order.

Like Joao, I also noticed that in the Users section of OneSignals, I still have no users registered. But on my Android phones, I have rebooted the app and logged in with several different accounts, yet none of them seems to have registered.

Did anyone else find a solution to this?

In the OneSignal setup, there is a section to setup the SDK and "get your first user". But there are no instructions for which setting to use for Outsystems. Anyone figured this out? Thought it might be relevant, since I can't seem to register my users.


Just wondering, have you included the RegisterWithUser action somewhere in your flow?

I encountered the 400:Bad Request error but after registration it works fine.

I am also able to see my test device as a user in OneSignal.

I hope this helps.