Skipping edit record validation

Skipping edit record validation

  
Hi,

is there a way to skip edit record validation? This is, if I have two edit records in the same page, is it possible to only validate one?

Thank's in advance,

Francisco Neto
Hi Francisco,

Make sure that your submit button has the parent edit record property set the the EditRecord that you want to validate.

Check also the validation property of your button.

Additional information on this subject can be found here:
http://www.outsystems.com/NetworkForums/ViewPost.aspx?PostId=6815
http://www.outsystems.com/help/servicestudio/4.1/Default.htm#web_user_interface/about_web_button_widget.htm
Regards,
Mário

Hello all

Can't I have a button with no validation? It always tries do find a widget as parent validation. I have two buttons on a page and one isn't supose to validade the editRecordsWidget but it does because when ParentValidation is empty by default it tries to validate all the widgets in the table. And the funny thing is it has other widgets in the screen but he only sees the editRecordsWidget.
It's typical behavior of the button as described in Button properties

Is there any workaround? Or is it recommended no to use two buttons in the same screen?
Thank you, best regards.

P.S. By the way the links above are not available anymore.
Updated links
About_Web_Button_Widget (for Service Studio 8.0 but you can change the link for the version you want
As for PostId=6815 link I didn't found it


To explain it better I have an editRecordWidget with save button (with validation).
And bellow on the same screen a tableRecordWidget with another button that I don't want to use any validation (but it always calls validation from editRecordWidget).
Thank you, regards
Pedro -

Did you set it to have a blank validation parent?

At the very worst, set the validation to "Server" instead of "Client and Server" and just do not check the .Valid of the EditRecord in the Action.

J.Ja
Justin James wrote:
Pedro -

Did you set it to have a blank validation parent?

At the very worst, set the validation to "Server" instead of "Client and Server" and just do not check the .Valid of the EditRecord in the Action.

J.Ja
 Or set it to None if you don't want validations...
 
Thank you Justin for your reply. My bad I forgot to set the validation option to "none" in the button I didn't need validation, sorry.  Pretty basic.

The funny thing was when I added a link (with no validation) with the same function in the same cell as the button. After a click in the link first and then other clicks after in the button, the button worked with no validation always.


Anyway thank you

Best Regards 


Yes thank you André that's exactly what I saw myself this morning. Just a couple of minutes and you would give me the answer ;) Sorry to bother with such a basic problem. Was working on other things too.

Thanks for your reply anyway, always very helpful