Help: Producer 'CommonPlugin' module definition is incompatible
Question

We have just migrating the server, and this problem occured...

Please help...


I already tried:

- delete then reinstall CommonPlugin

- compiling CommonPlugin manually, then compiling any module that depended on it.


Edit: I have to uncheck all references to CommonPlugin on all components and modules that dependent on it, then re-reference it.

Hi, I am also facing similar issue when I launch the quick app template in my iPhone 6s by scanning the QR code. How do I solve this issue  

Uncheck all references to Common Plugin in Manage Dependency Window, click ok. 

Then redo the references to Common Plugin.

I unchecked all the references and did it again but still the problem persist. I recently included firebase push notification module and then the problem started 

Any suggestions will be great !!


Thanks

Hi Mithilesh, 


I had the same issue. I removed the plugin altogether and reinstalled it and somehow the problem was gone. Having said that, I don't think either the above or my solution would work for sure. I would suggest you raise a ticket with Outsystems team and see what they have to say. Their response is usually quick! 

Hi Saket,

I managed to solve the issue. The went to the espace and checked all the dependency one at a time and found out that after I updated the common plugin the firebasemessageplugin was still not able to use that correctly and had a issue with it. I had to reinstall this particular plugin . I guess the best way was to check the dependency in eSpace and verify if at all there is an error or not.


Thanks for your reply 

I tried to resolve it with few suggestions which is given above. But for me i did it through this :
when i checked Template phone,Template tab, Template universal references in Manage Dependency Window, click ok. 


To resolve the issue, open Quick app Template in the IDE and open Module > Manage Dependencies... menu and click Refresh All button in the 'Manage Dependencies' popup window.

Thanks Dileep. It works :) 

I had the same use using the Health Fitness Plugin. I fixed it by cloning heath and fitness plugin so that I could open it, then rechecked the common plugin dependencies, then switched form inheriting health fitness plugin to the clone in the target app as well as rechecking the common plugin in that app as well.

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.