Users eSpace - Cant login ( Migration )

Hey team,

at this moment in our project we manage the users using the enterprise and service center system

we would like to migrate to the Users Espace.

The thing is that we are not able to login using any user even the default admin/admin

I've tried messing around in SQL Server creating some new users, roles and privileges with no success

I would like to know if you guys can share with me  a clone of the espace Users for version 9.1.609.0,

Thanks in advance,

Vincent Colpa

Hi Vincent!

Enterprise as in Enterprise Manager?

What do you mean when you say "we are not able to login using any user even the default admin/admin"?

What exactly did you do to migrate the users?

Hey João Heleno,

yes I mean Enterprise Manager to assign roles/privileges to our users. We would like to migrate the User Provider to the Users system.

We should have a user that is: username: admin and password: admin which is the default that would allow us to enter the Users eSpace but we aren't being able to.

So I went to SQL Server and tried a few things:

1- Checked in ossys_Tenant table and the Tenant_ID of the Users is 78 and ESPACE_ID is 80 

2- Created a new user in ossys_user with TENANT_ID = 78, username: newadmin and generated a new hash password to assign to the password from this link

3-Inserted in table ossys_User_Role some roles that we already are using including UserManager and Administator associatiating the Espace related to the Users

I Then tried to login in the Users eSpace but still without success.

Also i would like to point out, maybe it is relevant, that in the Administration section in the Environment Configuration there is an option titled: Authentication Provider if I see the options I dont have a Users available

That is why I was asking for a clone of the Users eSpace so I can check the actions and try to see what I am doing wrong,

Thanks in advance,

Vincent Colpa

What's the User Provider of Users (look in the meta table ossys_espace)?

Hey João Heleno,

thanks a lot for getting into this with me, as I can see I have an empty value in the user provider, as you can see in the image below

Thanks in advance,

Vincent Colpa

OK...sounds good.

What about error messages in Service Center?

Hi Vincent,

Just a question:

In step 3, when you did the insert in table ossys_User_Role did you also set the tenant_id to 78?



Hey guys,

Joao Heleno the errors I get are about user authentication,

José Costa yes I assigned the Tenant related to the Users eSpace,


We went to Service Center to the Users eSpace and assigned the "Effective User Provider" as "Self"

with that we were able to finally login in the Users eSpace.

But the weirdest thing just happened today i tried to login again but with no success. So I went to SQL Server to check it out and got this:

How is possible that my username just vanished away? Is it safe for me to use a query to update the username to 'admin' ?


Can you guys explain how can this happen?

Thanks in advance,

Vincent Colpa

Hey guys,

any feedback on this?

Thank you

Vincent Colpa

Don't know what to say about the username vanishing..

I'm going to ask for help.

Hi Vincent,

Could it be you still have the synchronization timers between Enterprise Manager and Users running, causing these problems?


Hello Kilian Hekhuis,

Guess It won't be related because I havent assigned the 'Users' as user provider to any of my eSpaces. The only thing I did by now was to sucessfully login into the Users eSpace and now we will be starting the migration of users, roles, etc

I checked out in SQL Server with this query which I executed for the time between our username and name was erased:

and the only Statments between those Dates are selects. I tried to filter it so it only show the update statments and returned no results, which made me more confused :>

Anyways, we updated the users password logged in a few times, created new users, new groups, changed passwords in Users eSpace and everything went smooth without cleaning the username and name again,

But i still keep thinking what could have caused that... how can I have no logs? So odd..

 I atached the SQL Query that I showed in that image for an easier copy paste,

Thanks for following guys

Vincent Colpa