SortList issue

  

OutSystems 10.0.613.0

I'm using the ListSort action from System and I'm getting weird results.

I build a record list of 8 columns: Text, Integer, then six Decimal columns.  It's put into a variable of Type Record List.

Once the record list is built, I use the ListSort to sort it by, say, "Column A's name from the structure".  I use the AJAX refresh on the table.  

The results are bizarre.  The results are not remotely sorted by any column, much less the requested column, and my debugging efforts show no reason, though the records move around as if they are being sorted.  The record list being sorted is the record list variable being used as the table's Source Record List.  I'm using the column name in the output structure as the SortBy column.

I also notice that the first record never moves, no matter which column I sort by.  I've used ListSort before successfully - no idea what I'm doing wrong now.

Solution

This is solved.

The issue was that ListSort takes a 'generic' variable type, and it seems to expect instead of a text the structure.column object instead, not the text name of the column.  Once I changed that, it worked.

Solution