[Infrastructure Monitor] DB Locks

Forge Component
Published on 2018-08-09 by Duarte Santos
22 votes
Published on 2018-08-09 by Duarte Santos


After installing Infrastructure Monitor and setting up to monitor 4 environments (total of 8 front-ends) we've noticed that the Lifetime performance server started to be impacted. Digging into it, we've found a lots of database locks.

From a brief investigation, looks like new Outsystems sessions are constantly being created causing a call to the standard Outsystems BD procedure TempGetAppID2 (P10) that has an explicit lock over the ASPStateTempApplications table.

Has anyone else faced this issue? Do you have any workaround?



I have heard of this before.  Please remove the block now

Hello Miguel.

I will investigate this issue.

Meanwhile, in order to try to mitigate this issue, please change the site property that increases the metric fetch time-window. Try increasing it to 45 / 60 seconds. The default is 30.

Will get back to you as soon as i have more insight.

Thank You 

Hi Duarte,

Thanks for your quick reply. Unfortunately decreasing the fetch frequency doesn't stop the DB locks. 

I've looked better into the lock and found that the issue is with the assign within the action FetchPerfCounterValues. As you're looping through all nodes and changing a site property (SP) value, the OSSYS_SITE_PROPERTY_SHARED table get's a transactional lock in the case you get any error on one of the Fetch actions just below, as the "happy flow" will not pass the existing commit. 

Committing the transaction just after setting the SP solves the issue. but I guess that's not not the desired behavior... Hope this helps you solving the issue!



Hello Miguel,

Your workaround is the way to go since this plugin needs to use the least AO's possible and creating another control table would use an extra AO.

Changing the data model to cope with this would require a query and an update on each action run.

A new version will come out in the next day or two with other fixes also

Thank You!