Sorry, but the phone 1234 does not accept the message ...

Sorry, but the phone 1234 does not accept the message ...

  
Hi,
I´m using a modem Siemens MC35i, Outsystems SMS Gateway, on RH 7.3, with the steps of the Guideline for Dummies, but something's wrong...

2 Situations:

1- Developed a oml that waits for a message, and replys some text ("Hello World!"). If i send a message from Service Center to this specific application, i receive the message "Hello World!".
Originator -> "My phone number "
Message -> "T"

Monitoring Page - > SMS

Instant - >2005-10-14 12:38:12
Large Acc. -> +3519xxxxxxxx
MSISDN - > 9xxxxxxxx
TYPE -> MO
MESSAGE -> T
Connection - >
ESPACE - > testeSMS

Instant - >2005-10-14 12:38:12
Large Acc. -> +3519xxxxxxxx
MSISDN - > 9xxxxxxxx
TYPE -> MT
MESSAGE -> Hello World!
Connection - >
ESPACE - > testeSMS


No problem so far, if i send the message from a mobile phone, i receive the message "Sorry, but the phone 1234 does not accept the message T"
Message To - > "Phone number defined on Service Center"
Message -> "T"

Monitoring Page - > SMS

Instant - >2005-10-14 12:38:12
Large Acc. -> 1234
MSISDN - > 9xxxxxxxx
TYPE -> MO
MESSAGE -> T
Connection - >
ESPACE - >

Instant - >2005-10-14 12:38:12
Large Acc. -> 1234
MSISDN - > 9xxxxxxxx
TYPE -> MT
MESSAGE -> Sorry, but the phone 1234 does not accept the message T
Connection - >
ESPACE - >

Has you can see no application received the message.
Why the large account "1234" ? Is this the default when the message cant be processed by none of the applications? Why it works from Service Center, and doesnt work from a mobile phone?


2 - On the SendSMS widget with the text "Hello World" i added a Preparation, initially on the preparation was a query to the table user, returned 1 row, and show the username on the message, but with the same steps on situation 1 i get no answer, so i simply removed the query, but the preparation remains, and no answer again. So, if i have a message with Preparation, this message isnt sent.

Monitoring Page - > SMS

Instant - >2005-10-14 14:46:15
Large Acc. -> +3519xxxxxxxx
MSISDN - > 9xxxxxxxx
TYPE -> MO
MESSAGE -> T
Connection - >
ESPACE - > testSMS

But no answer, no MT.

Any ideias?
Thanks


Hi Ricardo,

Situation 1 - Some GSM modems/ chip card combinations doesn't set the phone number (Large Account) in the inbound message (MT). To workaround this you must configure SMS Gateway configuration file ("\etc\smsgateway.conf"):
- In group "smsbox", add variable "global-sender = 9xxxxxxxx"
- Or, alternatively, add variable "my-number = 9xxxxxxxx" to group "smsc". You must restart it in order to load this new settings

Situation 2 - In which Hub Server and Service Studio versions did you detect this behaviour?

Regards,
Paulo Silva
Hi Paulo,
thanks for the reply, about your suggestion, i've tried both, but no luck, now in the large account the number is ok 9xxxxxxxx, but the message doesnt arrive the application, so i get the same message but with the correct number, it appears that the service center doesnt process the message, it simply reject it. But the strange is, inside the service center it responds, so i think the problem is when the message arrive... i'm using Share Mode by Keyword
In the Online Monitoring , the SMS Gateway, the status has a warning "A referência de objecto não foi definida como uma instância de um objecto."
About your question, i'm using Service Center 3.1.2.10 and Service Studio 3.1.2.18

Any new suggestion?

RJC