Force HTTPS Rendered All Application Inaccessible

Force HTTPS Rendered All Application Inaccessible

  

Hi, a newcomer to OutSystems, working on setting up environments. We currently have 2 environments (Development and Staging) along with LifeTime on its own instance. We had setup offloaded SSL on AWS and setup the correct HTTPS -> HTTP parameter in OSSYS_PARAMETER. While going through configuration on Development, I foolishly enabled "Force HTTPS for Screens" in LifeTime. After saving it quickly became apparent that was a mistake.

I attempted to set these options to OFF, and while it registered in LifeTime, it never registered in ServiceCenter because it could no longer reach the application. I realized that I couldn't change these settings in Service Center either (running 10.0.604.0). I opened the database and in OSSYS_PARAMETER I manually set the ForceScreensSecurity option to False. I also verified that there were no app-specific settings in OSSYS_APP_SECURITY. 

I then logged into the Windows 2012 instance on AWS. After reloading all OutSystems services and IIS, none of the applications were still reachable. What I did observe though is locally on the actual Windows 2012 instance I could reach them via http (i.e. http://localhost/ServiceCenter/) but I could not reach them externally via https (https://my.site.com/ServiceCenter/) despite the requests being forwarded to them properly. 

Does anyone have any ideas?

Solution

Hi Dean,

Of-Off setting through LifeTime console should have worked for you. However, you can read following documentation(click here) If it can help you.

Sachin

Solution

Thanks for your help. It turned out to be a misconfiguration in the load balancer. We offloaded SSL to it, and when I changed the setting to use HTTPS, the load balancer entered an invalid state. Restarted IIS and fixed the load balancer and everything came back online.