Action Get_Entity is reading from wrong table....

Action Get_Entity is reading from wrong table....

  
Hi....

I have this one app, with two database entries...

one is called osusr_9_bcs and the other osusr_4vO_bcs...

When i publish and use BCS, it writes into 4vO.

I have a link in this app, to an external one, which imports BCS's main entity, called BCS also...

When i do a Get_BCS, putting the id that came from the request, The Second App checks in osusr_9_bcs instead of 4vO....

Do you know how can i fix this ?

Best regards,

Diogo CS Cordeiro
Hi Diogo,

I'm not really sure what can be the problem. Have you tried recompiling the consumer eSpace? Also, in the consumer eSpace, click the add/remove references to see if everything is updated. Do you know why you have 2 database tables, have you cloned the producer eSpace or something similar?

Cheers,
Tiago Simões
Hi, i recompiled the producer, and also removed/reinserted the references...

I have two different databases because the first one was created before version 4.0, in which database nomenclature changed....Also, i had my espace removed and reinstalled, so i believe, and that's why the new version appeared...

What could be the solution for this?

Best regards
Hi Diogo,

Can you please contact support so that they can better trace your problem?

Best Regards,
Tiago Simões
Hi Diogo,

By design, it should not happen once both eSpaces are upgraded to 4.0. This seams like a product defect. Please contact OutSystems support and ask for a fix.
Thanks,
Lúcio