Maximum request length exceeded ASPNET 2.0

Maximum request length exceeded ASPNET 2.0

Hi i looked where should i change the config file for maxrequestlength and timeout, and found it out to be on file web.config.comment.

I changed that file, but still got the message maximum request length exceeded....

What can i do??
It's the "maxRequestLength" attribute of the "configuration/system.web/httpRuntime" element of "C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\CONFIG\machine.config"

Gustavo Guerra
It would be nice to update it, case it existed....

machine.config doesn't have any maxRequestLength attribute
In that case you can add it. The OutSystems Express Edition installer does that automatically.

Best Regards,
Gustavo Guerra
Yep, for future reference here stays how to correct this issue.

On Path


you will find in file machine.config the element system.web, with section processModel just beneath it.

The changes are adding right after processModel element line, the section httpRuntime, just as i write it below (it is case-Sensitive)


<processModel autoConfig="true" />

<httpRuntime executionTimeout="1200" maxRequestLength="20480" />

1200=20 minutes;

Best Regards,

Diogo C S Cordeiro



Just a reminder that in Windows x64 Architectures, the machine.config file is located at c:\WINDOWS\Microsoft.NET\Framework64\v2.0.50727\config\machine.config.




Miguel Simões João



FYI, I was bitten by this, too. I just did a download/install of the OS Platform and couldn't upload any extensions without receiving this error. My machine.config file did not include an httpRuntime element but after adding one my upload started working fine. (Also note that I followed the Installation Checklist instructions pretty closely and did not see this covered there.) Thank you for this forum posting! :)
Eric Kramer
Nationwide Children's Hospital
I had the same problem when I tried to publish the Epopeia Reporting eSpaces. Therefore I changed the 'httpRuntime maxRequestLength' in the machine.config.

According to this thread :
for 10MB the value should be : 102400. In my case I increased it to 20MB = 204800. After this change I could publish the Epopeia eSpaces succesfully.

In th example above is said that 20MB = 20480. I think the value should be 204800

<httpRuntime maxRequestLength = "102400" />

Dick Dokter

Hello All


If you have larger solution packs, you must increase the maxRequestLength setting in the machine.config, under the httpRuntime element.


Typically, the recommended values are:

  • 32 MB for small size factory environments
  • 64 MB for medium size factory environments
  • 100 MB or more for large size factory environments

This setting also impacts the upload of files to your applciations, like excel files, or documents, so you should adjust it accordingly.


From my experience, you should avoid uploading solution packs larger than 80 MB, specially if uploading onto heavly loaded environments.




Miguel Simões João

If you're running with IIS7 (supported in OutSystems Agile Platform 5.0) you may also have to change the following setting in machine.config:

Under system.webServer/security/requestFiltering, in the requestLimits element set maxAllowedContentLength attribute to the same value as maxRequestLength.

This is required for POST data requests (such as ServiceCenter uploads).
Hi all,

I'm facing the same problem but I've no success with those tags. I also modified the web.config file to incorporate <httpRuntime maxRequestLength="20480" /> but no success.

Any ideas?

Ricardo Brito
Hi Ricardo

Are you getting the the "Maximum request length exceeded" error message in the Service Center error logs? If not, can you detail what you're experiencing?


How can we check this in Java Stack?

Thank you.

Kind regards,

Hello Christopher, There's a setting you can configure in the JBoss application server. Please check the platform's Installation Checklist Tuning section, for the correspondent platform version and application server version. There's a step indicating the file and setting to change. For instance, in platform 9.1 checklist in, it refers to the setting max-post-size on the file /usr/share/jbossas/standalone/configuration/standalone-outsystems.xml Hope this helps. Cheers