[Network FileSystem] Can not get Directory listing from network share.

[Network FileSystem] Can not get Directory listing from network share.

  
Forge Component
(5)
Published on 2009-03-17 by Matthias Preuter
5 votes
Published on 2009-03-17 by Matthias Preuter

Hi all, 

We are trying to read files in a shared directory for example \\10.2.0.2\thisIsAShare

I want to get a directory listing.  I installed this module and configured it, however getting an error like :

c:\d:\OutSystems\Platform Server\running\TestApplication.05756482910Win32Error: 3
System.IO.DirectoryNotFoundException: Could not find a part of the path 'c:\windows\system32\inetsrv\thisIsAShare'.
   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
   at System.IO.FileSystemEnumerableIterator`1.CommonInit()
   at System.IO.DirectoryInfo.InternalGetFiles(String searchPattern, SearchOption searchOption)
   at OutSystems.NssNetworkFileSystem.CssNetworkFileSystem.MssDirectory_ListDirFiles(String ssDirectoryPath, Boolean ssSearchSubDir, RLFileRecordList& ssFileList, String ssDomain, String ssUsername, String ssPassword, String& ssError_message)

We have tried with a username and password, and without. getting same result.

Thanks in advance

Hello Tesaro,

have you overcome this situation?

Hi, yes, thank you. 

What was the solution?  I'm having the same issue with \\[server].[domain]\D$.  I get the it can't find a part of the path beyond "D$".  Does the "$" need to be escaped in the parameter?