ORA-00942: table or view does not exist

ORA-00942: table or view does not exist

  

Hi all,

I have an entity in a core module and I get this error when referencing it on an end-user module:

"ORA-00942: table or view does not exist".

Any ideas?


Edit: some additional information:

This error came up on an old table displaying records from the entity. The entity is located on a core module with "Public" as "Yes" and "Expose Read Only" as "Yes", as recommended by OutSystems. I believe this was not caused by new deployments, because the application was working fine after my last publish.

I have checked the error online (of course), and it seems to me that this was caused by database corruption of some kind. I have opened the core module in Service Studio and I was able to View Data without problems. However, in the end-user module, the View Data displayed the error described above.
I am using platform 10 and I upgraded the development environment yesterday to version 10.0.721.0.

I tried to remove the reference and add it again, but the error persisted on Service Studio. I published the end-user module and the error persisted.

I referenced the entity on another end-user application, created a TableRecords to display data, and it worked. I published that module and no error occurred. I entered the end-user where I had the error initially and the error has not appeared anymore.


Thanks,

Maria


hi,

have you, in the core module:


in the end user  module:


regards,

indra

Hi Maria,

could you upload a small application that exemplifies your problem? Could you also state the version of the platform you are using? In the meantime there are multiple checks that you can do, namely: 

a) Can you access the entity from within the core module itself? You could for example expose a rest service in the core module that returns a number of records of this entity and see if you get results. This is just for test purposes, so you can remove it once you did the check.

b) Can you access the entity from within the end-user module using an aggregate? Once again you could do this by exposing a rest service, this time in the end-user module.

b) Are you using an advanced query in the end-user module and doing an insert or update of a record of the entity whereas the entity is read-only in the core module?


greetings,

pedro

Hi Maria,

glad to hear that the problem is solved. 

greetings,

pedro

I would still like to know what caused this, since it appeared out of nowhere. We can't have this type of issues in PRD enviroments.

Hi Maria,

I understand your concern. I would say that some kind of corruption took place the moment you published the module. I also faced such a problem a while ago. Republishing the module helped. 

If you wan't to know what caused it, I believe you can better open a support case and send OutSystems all the logs they ask you. I would expect the problem to be at the platform server level.

Personally, I wouldn't be that much concerned with whether this happens in production. It could be detected with some functional testing and it can be solved fast by republishing the module. But this is purely my view on it. You have the right to be more concerned.


pedro

Update: I am now experiencing the same issue with another aggreggate with other core entities from another core module, and on a separate end-user application.

Hi Maria, what is the version of the platform server? Maybe it could be a mismatch between the Service Studio version and the platform server version causing the problem. You only saw the problem after installing the newest version of Service Studio yesterday, right? You could try to get back to the previous version of Service Studio you were using.

Pedro, the platform server version is 10.0.705.0. I was already installing the previous version of Service Studio but it is still happening. I am now going to try to roll back all developments published in the new service studio version.

Hi Maria, let us know if it helped. I would expect so.

Pedro, no success. Already restarted both the database and the OS server (just in case) and no success as well. I'm running out of ideas...

Hi Maria, could you try to publish the modules that are giving problems from within service center itself. I would suggest to publish, not the latest version, but the one just prior to your changes after which you started getting problems. This way we put Service Studio out of the equation. I would expect those modules to start working properly. Its worth a try I guess. If this works than you could redo the changes you did from within Service Studio but always starting from these versions onwards.

Good luck!

Pedro, I tried that too. It failed.

You could try to create a solution with all modules you have in dev and do a full compilation. 

If this does not work you can try to delete the application containing the modules and publish it again. First do a backup of the multiple versions of these modules you have in dev. 

Hope it works. 

Hi mariap,

If Oracle is giving an error saying that the table does no exists in a module, but the same table can be reached from a different one, could you dolook a simple test?

Reproduce the aggregate that is giving problem in a module where it works, than open the aggregates and compare the executed query in both to see if there is any difference in the sql being sent to database.

Just be careful with recreating modules, as the entities on them will also be recreated in database and this can pose a serious problem if the application is already in production.

In any case, this is probably a case for OutSystems support.

Cheers.

Hello all.

Pedro, I tried to publish all modules using a Service Center solution, no success either.

Eduardo, yesterday I reproduced the same aggreggate in a different module and I compared the executed queries and no diferences were found either. Either way, yesterday I also decided to open an Outsystems support case.

Thanks for all your suggestions,

Maria

Hello Maria,

When you find the cause/solution, please, share it here and mark your answer as the solution. :)

Cheers

Hi all,

This error was coming just because of the outsystem version incomaptibility. I was facing the same error and it solved just after updating my outsystem platform version to latest. This happens when the application is developed in the older or latest version and you are using it on the older or latest version of the platform.


Cheers,

Hassan Malik

Hi Hassan, could you specify the versions in question? Both the version of service studio and the version of the platform server? That would be handy for others facing the same problem. 

Greetings, pedro