[ardoHTTP] how to set timeout for http requests in ardoHttp

[ardoHTTP] how to set timeout for http requests in ardoHttp

  
Forge Component
(16)
Published on 30 Oct (14 days ago) by Ricardo Silva
16 votes
Published on 30 Oct (14 days ago) by Ricardo Silva

Any suggestions?

You should be able to use a header to define the timeout. If you read the documentation for the Headers parameters there are a few special headers which control the behavior of the request.

Also, nowadays you should probably be using the platform's builtin rest functionality to make HTTP requests, not ardoHTTP.

Ricardo Silva wrote:

Also, nowadays you should probably be using the platform's builtin rest functionality to make HTTP requests, not ardoHTTP.

For some strange reasons, some destinations (publisher) keeps rejecting the requests arising out of inbuilt REST action, however, that is not the case with ardoHTTP.

Interesting to note that, when you are TESTing the Consume Single Method while importing REST service, it works fine. Is it probably because outsystems cloud is having some outgoing settings conflicting (for REST inbuilt API consumer)? Because when we TEST, the request goes from local network and not through outsystems cloud.