[PhoneCall] Phone call plugin for IOS

[PhoneCall] Phone call plugin for IOS

  
Forge Component
(3)
Published on 2017-08-09 by Sachin Mahawar
3 votes
Published on 2017-08-09 by Sachin Mahawar

Hello ... I am a newbie to OutSystems development.

I was trying the PhoneCall plugin but I get a "undifined is not an object (window.plugins.CallNumber.callNumber)" error.

I was wondering is this a IOS only issue? If so - is there a phonecall plugin I can use on IOS?

Regards

L Pieters

Hi Louw,

If you test the plugin in Outsystems Now you can get an error message like this. Third party plugins are not useable in the Outsystems Now enviroment. You must deploy a native app to use a 3th party plugin.

Regards,

Furkan

Furkan Çetin wrote:

Hi Louw,

If you test the plugin in Outsystems Now you can get an error message like this. Third party plugins are not useable in the Outsystems Now enviroment. You must deploy a native app to use a 3th party plugin.

Regards,

Furkan


Thank you very much for your reply Furkan. Yes I was testing on OutSystems Now. Will try native. 

Regards

Louw Pieters

Louw Pieters wrote:

Furkan Çetin wrote:

Hi Louw,

If you test the plugin in Outsystems Now you can get an error message like this. Third party plugins are not useable in the Outsystems Now enviroment. You must deploy a native app to use a 3th party plugin.

Regards,

Furkan


Thank you very much for your reply Furkan. Yes I was testing on OutSystems Now. Will try native. 

Regards

Louw Pieters

Agree with Furkan, Try it native.

Sachin


Sachin Mahawar wrote:

Louw Pieters wrote:

Furkan Çetin wrote:

Hi Louw,

If you test the plugin in Outsystems Now you can get an error message like this. Third party plugins are not useable in the Outsystems Now enviroment. You must deploy a native app to use a 3th party plugin.

Regards,

Furkan


Thank you very much for your reply Furkan. Yes I was testing on OutSystems Now. Will try native. 

Regards

Louw Pieters

Agree with Furkan, Try it native.

Sachin


Thanks Sachin, will do so  


Regards

Louw


Louw Pieters wrote:

Sachin Mahawar wrote:

Louw Pieters wrote:

Furkan Çetin wrote:

Hi Louw,

If you test the plugin in Outsystems Now you can get an error message like this. Third party plugins are not useable in the Outsystems Now enviroment. You must deploy a native app to use a 3th party plugin.

Regards,

Furkan


Thank you very much for your reply Furkan. Yes I was testing on OutSystems Now. Will try native. 

Regards

Louw Pieters

Agree with Furkan, Try it native.

Sachin


Thanks Sachin, will do so  


Regards

Louw


Hi Louw

We have used this plugin in one off our projects and it works on both Android and IOS. As per previous comments they are correct and you have to use this in a Native app to test and use