Trouble opening espace page via servicecenter

Trouble opening espace page via servicecenter

  
Hi. I'm a new Out Systems user.

When i'm at home and click on a espace link in the espace list of service center, which has links like this:
javascript:__doPostBack('widget27356$_ctl75$wtLink4','')
my browser times out waiting for a response. I end up with a built-in IE page saying that the page could not be displayed.

This is the error in the servicecenter Error Monitoring:
[1] Invalid_Viewstate_Client_Disconnected
Client IP: 212.238.150.173
Port: 1111
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
ViewState: <very much characters, deleted>

However when i click on a espace id via the servicecenter Monitoring page, the page does get loaded. In this case the links are like this:
http://hostname/servicecenter/(gpx5ipyltrpepsmqslbcrz55)/node752.aspx?in21806=196

Also when i try to upload a espace via Service Studio, the process hangs. I'm forced to kill Service Studio.

At the office everything is working ok. My setup at home is Windows XP with IE browser. The home connection is shared with linux. Maybe i need to forward some ports?
Hi Michael,
Are you using the same PC at home and at the office ? If you are then you probably should be experiencing the same problems at both locations. If not then check what's different between both machines. I'm thinking of firewall/antivirus software more than anything else. Invalid or corrupt viewstates usually mean the browser didn't submit all the necessary information, that was present in the page, to the Hub Server.

As for the timeout page you get, I've experienced that problem with Internet Explorer when IE is disconnected from the server and even though it receives a page with an error message it simply does not display it. If you had a proxy in between you would see the error page generated by your request.

We've never had any problem uploading eSpaces, nor browsing the eSpace list at Golden Bytes Service Center.

As for your question regarding port forwarding, there are no requirements for any special open ports to use Service Studio. If your browser can access Service Center then Service Studio shouldn't have any problems accessing it either.

When experiencing this kind problems feel free to use the support email.

Best regards,
Marco Cunha
Engineering
OutSystems
Hi Marco,

Yesterday evening i tried to do it again. Opening a eSpace page via the eSpaces list in servicecenter from home. This time it worked. Nothing has changed in the setup. The loading does seem to take a while, and is probably on the brink of timing out.

Since it worked i also came to the conclusion that probably nothing mayor was wrong. Apart from maybe a network problem between my home pc and the server, or maybe a server that's very busy. I forgot to try to upload a eSpace, i'll do that tonight.

I did have to uninstall McAffee antivirus because it was interupting Service Studio while it was uploading a eSpace. After that service studio still hanged in the uploading stage. I suspect this is a ordinary networking problem. I've got simple traffic shaping set up on the linux router (TBF). This seems to affect the performance of transfers on MSN and Soulseek. I'll remove the shaping rules tonight and check if the OutSystems related problems are solved.

Thanks for your answer!