[Geofence Plugin] Update plugin Swift version

Forge Component
(0)
Published on 2019-08-28 by Experts
0 votes
Published on 2019-08-28 by Experts

Hi,

We would like to add this plugin to our app but unfortunately the current plugin version only supports Swift 2.3 and it comes into a conflict with some of other plugins that are already in the app and are using Swift 3.0. 

It would be really nice to have this plugin swift version updated.

Thank you.

There is a fork for plugin with updated Swift to version 3 https://github.com/compelling/cordova-plugin-geofence.git


Mykola (Nick) Tkachenko wrote:

There is a fork for plugin with updated Swift to version 3 https://github.com/compelling/cordova-plugin-geofence.git


Hi Mykola,


how di I install this Plugin from git? I have no idea?
Kind Regards

Thomas


Mykola (Nick) Tkachenko wrote:

There is a fork for plugin with updated Swift to version 3 https://github.com/compelling/cordova-plugin-geofence.git


I build up a new plugin, with your Link from gibt, but git this:

"Error generating application. At least one Cordova plugin used in the build requires Swift but no "Swift Language Version" build setting was defined. Check your plugins configuration."


Any ideas?