Internal trace failure: Not implemented for TextResources

Internal trace failure: Not implemented for TextResources

  
Hi,

I can't comiple ( and deploy) the espace eMailServices.

How can I overcome this error?

I already did try exit from the ServerStudio, stop the services, shutdown the server.... but nothing works!
Thanks,
Maria de Lurdes Spínola

P.S. The error I get is this:

Internal Error
Internal trace failure: Not implemented for TextResources.
Exception Details:
[1] Internal Error: Internal trace failure: Not implemented for TextResources.
at System.Diagnostics.DefaultTraceListener.Fail(String message)
at System.Diagnostics.TraceInternal.Fail(String message)
at System.Diagnostics.Trace.Fail(String message)
at #qk.#pk.#Ds(XmlElement elm, #Rl lang, #Kj parentCompObj)
at #qk.#pk.#Bs(XmlElement elm, #Rl lang, #Kj parentCompObj)
at #qk.#pk.#Ds(XmlElement elm, #Rl lang, #Kj parentCompObj)
at #qk.#pk.#Bs(XmlElement elm, #Rl lang, #Kj parentCompObj)
at #Lj.#3m..ctor(XmlElement elm, #Kj parent)
at #Lj.#Wm..ctor(XmlElement elm, #Nj parent)
at #Lj.#Sj.#Kq(XmlElement elm, #Nj parent)
at #Lj.#Nj.#zp(XmlElement elm)
at #ro.#yo..ctor(XmlElement elm, #Kj parentCompObj)
at #ro.#vo..ctor(XmlElement elm, #Kj parentCompObj)
at #Lj.#in.#JI(XmlElement elm, #Kj parent)
at #ro.#to..ctor(XmlElement elm, #Kj parentCompObj)
at #ro.#so..ctor(XmlElement elm, #Kj parentCompObj)
at OutSystems.HubEdition.Compiler.Espace..ctor(XmlDocument doc, #Kj parentCompObj, Int32 eSpaceVersionId, String testname, TypeMapper typeMapper)
at #Lj.#Ac.#is()
at #Lj.#Ac.#ks(String[] args)
at #Lj.#Ac.#Pe(String[] args)
Hi Maria,

Would it be possible if you could click the "Submit Feedback" button that appears when you try to publish this eSpace so that our support team can look into it? This way they would have more information about the problem you are describing.


Thank you very much,
Tiago Simões
Hi Tiago,

I already did click the "Submit Feedback" ( in 2007/08/23 ).

I don't know if you can "see", in this forum my email address, but if you can, the "Submit Feedback" have the same email address, and if you can't "see" my email address, maybe there is a way of me getting access to the data that goes in the "Submit Feedback" so that I can copy and past in this forum?

I really appreciate your dedication,
Maria de Lurdes Spínola
Thanks Maria,

The information sent is really low level, just a few technical information about your system and more ugly error stacks. I don't think you and I would make anything of it :) but our Support Team should be looking into it, and they'll let you know more soon.

Cheers,
Tiago Simões
Hi Tiago,

I already receive the answer from the OutSystems Technical Support.

I will post their replay here, because someone else may have the same problem in the future ( I hope not ), and this post can help them!
Thanks,
Maria de Lurdes Spínola
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Begin of the answer from the OutSystems Technical Support
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++


Hi,

Thank you for reporting your feedback.

To overcome this problem we suggest reinstalling the OutSystems Express Edition. Just run the Express Installer again and reinstall Service Center component.

Best regards,

Carlos Cabral

Technical Support Engineer

OutSystems

www.outsystems.com
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
End of the answer from the OutSystems Technical Support
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Hi.

This is a known problem (#59910) that has been fixed in version 4.1.3.10. Make sure you're using that version.

Best Regards,
Gustavo Guerra
Hi,

I was sure that I had the OutSystems Express version 4.1.3.10 when this problem did happen ( I did the upgrade some days before this problem start to happen ).

Can you check what version was I using when I did send the feedback ( in 2007/08/23 ).

Why am I asking this?

Because, I did reinstalling the OutSystems Express Edition, and another problem did happen. I could not finish it with success ( the error was in the sp_changedbowner, in line 46 - the changedbowner is in attachment -, for the user sa, or any other user I did create to overcome this new problem)

Anyway, I did ask for help, at my office, and we could not find in "OutSystems System Requirements", if the version 4.1.3.10, could be installed with the SQL Server 2000.

So we end by installing the SQL Server 2005.

So my question is this:
- Could it be possible, to have the OutSystems Express version 4.1.3.10, with SQL Server 2000?

Thanks,
Maria de Lurdes Spínola
Hi,

You can use OutSystems Express with SQL Server 2000, SQL Server 2005 or SQL Server Express 2005, as long as they are installed in the same machine.

According to your Submit Feedback about the TextResources problem, you're using version 4.1.3.10 of Service Studio, but the Service Center was still version 4.1.3.6. Make sure you reinstall all components, and not just Service Studio.

As for the sp_changedbowner, we have received your feedback about it and it is being worked on by our Engineering Team. As a workaround, delete the catalog OSASPState from the database and try installing 4.1.3.10 again.



Best Regards,
Gustavo Guerra