Tip: DW20.exe is spiking to 100% CPU

Tip: DW20.exe is spiking to 100% CPU


In the task manager of your server, you'll find a process called DW20.exe, that occasionally spikes its CPU consumption to 100%.


The DW20.exe process is part of the Windows Reporting Tool for Microsoft Office applications that stop responding. The CPU spikes are due to the collecting information process, and may cause CPU resource exhaustion temporarily. This as impact of highly loaded application servers.

The obvious solution is to disable this Microsoft Office applications Reporting Tool. In order to achieve that, you can disable the Application Error Reporting Tool by adding a Registry entry DWReportee with value 1 to the following registry keys:

HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\PCHealth\ErrorReporting\DW HKEY_CURRENT_USER\Software\Microsoft\PCHealth\ErrorReporting\DW

as explained in KB841477

Additionally, you can disable it through the Office Application Error Repoting Tool, as described in KB325075.

Or, my favorite, you can disable error reporting all together by following the steps:

1. Go to Control Panel.
2. Click System.
3. Go to the Advanced tab.
4. Click Error Reporting.
5. Click the "Disable Error Reporting" radio box

Et Voilá, no more DW20.exe hogging up your precious CPU.

Hope you've enjoyed this one ...


Miguel João
You can also simply disable Dr Watson at all, by following the instruction in this KB article from Microsoft:


This will disable DrWatson on the computer where this procedure is applied. Take special attention to the instructions, should you need to re-enable DrWatson on your computer.
Since the methods above are focused on 2003/XP, here is how to disable DrWatson (A.K.A dw20.exe or Error reporting) in Windows 2008 and 2008 R2:

1) go to control panel, make sure your "view by" is set to small icons;
2) click system;
3) click "Action Center" in the lower left corner of the window;
4) expand "Maintenance" section;
5) under "check for solutions to problem reports", click "Settings";
6) click the "change report settings for all users" link below the options;
7) select "Never Check for solutions", click OK.