Integration Studio keeps giving error after defining .Net IDE path

Integration Studio keeps giving error after defining .Net IDE path

  

Hello fellows,

I dunno why but after specifying devnev.exe path for .Net IDE in Integration studio configuration and clicking OK or Apply I keep getting this error (see the attachment).  I check VS2017 files and everything looks fine.  I also removed and reinstalled the Outsystems stuff on my machine and issue still remains.  Anyone has any idea why and how to solve it?

Hi Daniel,

What version of the OutSystems Developement Environment do you use?

Kilian Hekhuis wrote:

Hi Daniel,

What version of the OutSystems Developement Environment do you use?


The latest one. Version 10.

Daniel Xu wrote:

Hello fellows,

I dunno why but after specifying devnev.exe path for .Net IDE in Integration studio configuration and clicking OK or Apply I keep getting this error (see the attachment).  I check VS2017 files and everything looks fine.  I also removed and reinstalled the Outsystems stuff on my machine and issue still remains.  Anyone has any idea why and how to solve it?

I would check Windows event logs for any suggestions what might be happening. I suppose you have admin rights to your windows machine as you are installing/uninstalling stuff (instead being restricted to something more corporate)?

Also, MSBuild folder is pointing to version 12, while I have version 14. You might want to check your Visual studio installation once more.


Hi Daniel,

Version 10 is more like a generation than a version. The version can be checked in the About / Help menu.

Solution

You can get it done when you run Integration Studio as Administrator, change the options for the development environment. Once you've done that you can run Integration Studio without Administrator privileges.

Solution

Danny Creusen wrote:

You can get it done when you run Integration Studio as Administrator, change the options for the development environment. Once you've done that you can run Integration Studio without Administrator privileges.

Thanks Danny!  Dunno why I need to run it as Admin but the issue is solved!!


Mikko Nieminen wrote:

Daniel Xu wrote:

Hello fellows,

I dunno why but after specifying devnev.exe path for .Net IDE in Integration studio configuration and clicking OK or Apply I keep getting this error (see the attachment).  I check VS2017 files and everything looks fine.  I also removed and reinstalled the Outsystems stuff on my machine and issue still remains.  Anyone has any idea why and how to solve it?

I would check Windows event logs for any suggestions what might be happening. I suppose you have admin rights to your windows machine as you are installing/uninstalling stuff (instead being restricted to something more corporate)?

Also, MSBuild folder is pointing to version 12, while I have version 14. You might want to check your Visual studio installation once more.


Thanks Mikko.  I can install software freely but your indication is right.  After running Integration Studio as Administrator just as Danny suggested the problem is solved.  Dunno why...

Regards,