API level 23 to API level 26

API level 23 to API level 26

  

Good afternoon,


I'm trying to publish a mobile application to the Android store. After generating and downloading the .APK, I get an error in the developer area of android when uploading the .APK. 


It says that the app is targeting towards API level 23, but it should target to API level 26. 

Anyone a solution?

Same Problem here running 10.0.815.0 of the Developer Tools

Have the same issue,running 10.0.815.0 service studio

Have the same issue,running 10.0.815.0 service studio

Have you create support ticket for this?

I will soon need to publish to Play Store too...

Solution

Hi everyone, this is the answer thah i got from the customer support team:

In order to change the minimum SDK version to be used on our application, all we need to do is add the needed minimum SDK configuration, to the Extended properties attribute in our application.

example : 

{
    "preferences": {
        "android": [{
            "name": "android-minSdkVersion",
            "value": 26
        }]
    }
}
Solution

Thank you for sharing.

It's really useful. 

Ervin Winardo wrote:

Hi everyone, this is the answer thah i got from the customer support team:

In order to change the minimum SDK version to be used on our application, all we need to do is add the needed minimum SDK configuration, to the Extended properties attribute in our application.

example : 

{
    "preferences": {
        "android": [{
            "name": "android-minSdkVersion",
            "value": 26
        }]
    }
}


hi 

i already add this in extenbility configuration of my project but still has same problem to add in google play it need android level 26+ can you tell me what can i do

also i attach screen shot please help me guys 

mohammad rahimi wrote:

Ervin Winardo wrote:

Hi everyone, this is the answer thah i got from the customer support team:

In order to change the minimum SDK version to be used on our application, all we need to do is add the needed minimum SDK configuration, to the Extended properties attribute in our application.

example : 

{
    "preferences": {
        "android": [{
            "name": "android-minSdkVersion",
            "value": 26
        }]
    }
}


hi 

i already add this in extenbility configuration of my project but still has same problem to add in google play it need android level 26+ can you tell me what can i do

also i attach screen shot please help me guys 

Is there anybody who can help with this problem? It is possible to publish android application in the Store right now, but after August level 26 is mandatory


Hi, try to change your Extensibility configuration to match the same schema order as described in this article
https://success.outsystems.com/Documentation/10/Delivering_Mobile_Apps/Customize_Your_Mobile_App/Extensibility_Configurations_JSON_Schema


Hi,

I encountered the same issue today, when generating the apk google reported it as version 23.
After generating the apk I used Apktool to inspect it to see what the min SDK was set to, it seems that when generating it through Outsystems even after setting the minimum SDK version it will stay at 15.

I got around this by changing the Sdk target to 26.

Here's a snippet

{
    "preferences":{
            "android":[{
                "name": "android-minSdkVersion",
                "value": "26"
            },
            {
                "name":"android-targetSdkVersion",
                "value":"26"
            }]
    }
}

what is the purpose of below attributes :

 android-targetSdkVersion


If we do not mention it in Extensibility configuration, will that be any probelm ?