[Screen Orientation Plugin] Problem with orientation Plugin in iOS

[Screen Orientation Plugin] Problem with orientation Plugin in iOS

  
Forge Component
(5)
Published on 2016-11-08 by Experts
5 votes
Published on 2016-11-08 by Experts

Good Afternoon, i've found a problem with the plugin in iOS where the app renders the screen only in half when you unlock and lock the position again. After some research i found out that the extensibility used on the plugin is outdated, the newer version of the cordova plugin on https://github.com/apache/cordova-plugin-screen-orientation has the issues fixed. 


Best Regards,

Fábio Santos


Fábio Santos wrote:

Good Afternoon, i've found a problem with the plugin in iOS where the app renders the screen only in half when you unlock and lock the position again. After some research i found out that the extensibility used on the plugin is outdated, the newer version of the cordova plugin on https://github.com/apache/cordova-plugin-screen-orientation has the issues fixed. 


Best Regards,

Fábio Santos


Hi Fabio,

For orientation configuration, this may be helpful https://success.outsystems.com/Documentation/10/Delivering_Mobile_Apps/Customize_Your_Mobile_App/Set_the_Preferences_for_Your_Mobile_App

or  can't you update the plugin url version in extensibility configurations ?


regards,

ali amin

ali amin wrote:

Fábio Santos wrote:

Good Afternoon, i've found a problem with the plugin in iOS where the app renders the screen only in half when you unlock and lock the position again. After some research i found out that the extensibility used on the plugin is outdated, the newer version of the cordova plugin on https://github.com/apache/cordova-plugin-screen-orientation has the issues fixed. 


Best Regards,

Fábio Santos


Hi Fabio,

For orientation configuration, this may be helpful https://success.outsystems.com/Documentation/10/Delivering_Mobile_Apps/Customize_Your_Mobile_App/Set_the_Preferences_for_Your_Mobile_App

or  can't you update the plugin url version in extensibility configurations ?


regards,

ali amin

Hi, i've updated and its working fine i just posted this in order to inform the team who developed the plugin or whoever runs into the same problem.

Cheers,

Fábio Santos