[Excel Report] Record doesn't write to excel when exceeded 10 rows

[Excel Report] Record doesn't write to excel when exceeded 10 rows

  
Forge Component
(5)
Published on 2017-11-27 by Miguel Meireles
5 votes
Published on 2017-11-27 by Miguel Meireles

Hi

I encountered a problem whenever the record is more than 10 rows, the records started from the 11th of the records will not be written into the exported excel. I have checked the xml, total 17 records in it, but only 10 records were written into excel. 

May I know is there any setting on the maximum rows that we can write to excel? 

Anyone can help?

Thanks.



Hi XiaoHui,

I think the maximum of lines that excel can write are 1,048,576. 

From what I'm seeing in the code above, you're telling excel to write on sheet 1 and to start on line 18. 

in the excel template do you have some rules in the lines that might be causing you not to see more records? 

can you send the excel template you are using and ?


Best Regards

Miguel Meireles


Hi Miguel

Thanks for your reply.

I downloaded the excel template from the Demo page and modified it to my own format. Attached with the excel template that I'm using.


XiaoHui,

I think the problem is in excel. I changed some properties in the cells, and the results started to appear.
I leave here a link where you can test http://mmeireles.outsystemscloud.com/teste_Excel/test.aspx 

select option "generatedata2"

I send the changed excel, however I would say to create a new excel.


Hi Miguel

I tested using the edited excel file from you, it working properly, all results show up and file can be opened properly.

As your advice, I created a new excel file, the results shows up, but encountered the error below when open the file. Attached with the new excel file that I created, can you try on my excel see whether you have the same error?

Thanks in advance!


Hello XiaoHui

I put the file in the same link I did not have an error.

Usually this error happens because of the data that is being placed in excel.
Can you send me some of the data you're putting in excel.

Hi Miguel

This is the file that I exported with values. I am using the excel template that edited by you in this reply (https://www.outsystems.com/forums/discussion/37845/record-doesnt-write-to-excel-when-exceeded-10-rows/#Post137394


Can you create excel without data and see if it gives the error?
In the decimal values when you send the format is '33,00 'or do you send '33.00'?


Hi Miguel

I tested without data, it working fine. I send 33.00

I tried to load first part of data it, it working fine also. When load second part data in, the error occurred. But the data is just text and integer, cell format also same in first part.

I tried to copy first part cells to replace in the of the cells, load data and export the excel, it works fine. It seems the cells causing the error, but the problem is, I can't find strange behaviour in the cells.

So, I will use the working copy on my work for now.

The component is working perfectly, the problem is in my excel template. But the root causing is still remain unknown for my case.

Anyway, thanks for creating this useful component and prompt reply from you. 

Must appreciated and thank you.