403 error when navigating to a page

403 error when navigating to a page

  

We are experiencing a quite puzzling error. We have an espace that contains three webpages. When you login you get to a homescreen which has 2 links each of those does a navigate action to a new page. All of these pages have the same rights.

Navigating to page A never gives a problem, but navigating to page B will sometimes return a 403 error. This only happens when approaching the page from the external front-end server, from the internal server this problem does not appear.

We've also tried approaching the page directly through the URL. The error occurs when we try navigating to: https://{environment}/{espace-alias}/WebScreen.aspx

but not when we try the following urls:

  • https://{environment}/{espace-alias}/webscreen.aspx (<-the only difference being the capital letters)
  • https://{environment}/{espace}/WebScreen.aspx

Unfortunately there is nothing in the service center logs to give us any clue about what is happening. We also checked the IIS log on the external front-end server where we could find the 403 error, but no additional information about the cause of the error. We do know that there is no webservice call on page B, in fact it never even gets to the preparation of the page. Also, this error only started appearing after we upgraded our Platform server to version 10.0.828, it persist on our acceptation server after we upgraded that to 10.0.900.

Currently our options as a work-around are to either remove the espace alias or to implement a page rule to change the url that the links navigate to.

Does anyone have any experience with similar issues, or perhaps a suggestion for a different solution?

# hi, have u tried all these work arounds?

https://www.lifewire.com/403-forbidden-error-explained-2617989

regards


# Box wrote:

# hi, have u tried all these work arounds?

https://www.lifewire.com/403-forbidden-error-explained-2617989

regards


Thank you for your reply. We have tried those fixes, unfortunately they didn't work.

Solution

Hi Herre,

Do you have any security layer around your external server? 

Had some similar situation, the problem was the firewall blocking every requests from the external server to the internal. Also the configurations on the firewall were case sensitive validating the virtual directory (eSpace). Just allowing the eSpace on the firewall solved the issue.

Hope this helps.

Cheers 

Solution

Thank you for your reply. There is a security layer around the external server yes. We'll investigate this and update when we know more.

It was indeed an issue with the firewall stopping some requests. The party maintaining the firewall made some adjustments that seem to have fixed the issue.