[Event System] Event System use for license

Forge Component
(32)
Published on 24 Mar (yesterday) by leonardo.fernandes
32 votes
Published on 24 Mar (yesterday) by leonardo.fernandes

Hi,


I am trying to use event system to trigger action in webblock from parent screen and I am getting the below error. Do we need license to use event system?


http://leonardofernandes.outsystemscloud.com/licensing/use.aspx?f=evt&h=test.com.sg&e=Test4&ac=A7L.UGQ.GDO.GVY.3LC.ICW.3JJ.AOU&p=false&osv=8.0.1.25&cv=8.4.9.net&v=False&_=1537326949922

Hi. Where are you seeing that error? If that error is affecting your application, let me know and I'll provide you with a patch.

It seems that you're using a very old version of Event System. That version used to be licensed to have access to the source code, but newer versions are not licensed at all.

leonardo.fernandes wrote:

Hi. Where are you seeing that error? If that error is affecting your application, let me know and I'll provide you with a patch.

It seems that you're using a very old version of Event System. That version used to be licensed to have access to the source code, but newer versions are not licensed at all.


I am seeing this error when Trigger event is fired. I am using the version for OutSystems 8. 

Does it always happen when you call Trigger? And is it displayed to the user, or just logged somewhere?

leonardo.fernandes wrote:

Does it always happen when you call Trigger? And is it displayed to the user, or just logged somewhere?

It always happen when Trigger event is called. The above link with 404 error was captured in network log of chrome browser.