Error Sending Email with Correct SMTP Configuration

Error Sending Email with Correct SMTP Configuration

  

Hello, I am just trying to learn how to send emails with Outsystems in my Personal Environment APP, and supposedly I have the right configurations on my Email Configuration (Service Center -> Administration -> Email).


But now these errors keep popping in my Error Log (Monitoring - Errors) and I am not even calling the action to send the email in my Personal App anymore.


(I will transcript the error in case you cannot see the image properly)

Error sending email 33: 534-5.7.14 <https://accounts.google.com/signin/continue?sarp=1&scc=1&plt=AKgnsbt-
534-5.7.14 az6QfStKX-raLLru7g3SiseunaU8z4d9k2ZAnHCvn_oB7jRMbOZ_1AG0z5pNaEAoB83-Mm
534-5.7.14 Vjt-ttmOG1kJEadOha6gWvlBZBJfSIIQQ6O3opXRJMA1IcLHR9UaJp8oCwWH1zzcTrgZ6s
534-5.7.14 5j_d20f07YZ3LjIYwl-nBYHn-nIlb3BaQ0xqEHyoDwC_N5B4maWVJbwTfxZ2mhGOYhgoEr
534-5.7.14 77pNpmIMR7hyCxAIZpNUGlApN0ZL_SfD36qAFo3f5n8-Y8_1_THjAbfrHVF4L2jkO-8rMj
534-5.7.14 1u9qhTYJYKDQGAtYVqhXXKNuq_6ZGIDDc1hXDa6De50zX3f8IZSM1VySB9uxcBSIMesG-b
534-5.7.14 Uo8zjAhtC2gVb1Q5nvqxtudZRtsF30XEN-j4PiRrAy9pyNV2ecq6au6H9MQjigI7PHprTy
534-5.7.14 ujcD1jJdsufSbl3f26k6U4O8ZKN-1H1rCVKcU9m908c4Q79TQfNjZzALN8XdJN8A6qsDeT
534-5.7.14 NgrpM> Please log in via your web browser and then try again.
534-5.7.14  Learn more at
534 5.7.14  https://support.google.com/mail/answer/78754 k3-v6sm2386967qtm.12 - gsmtp
UG9seTNHbG90aW5hcm93



Thank you for your help :)

Solution

Hi, 

This error is not about OutSystems, but about a Google Configuration.

-First you need to go to: https://myaccount.google.com/security?pli=1#connectedapps

-Then you should change the option "Allow less secure app" to "Yes"


I hope this can help you.


Best regards,


William Antunes

Solution

William Antunes wrote:

Hi, 

This error is not about OutSystems, but about a Google Configuration.

-First you need to go to: https://myaccount.google.com/security?pli=1#connectedapps

-Then you should change the option "Allow less secure app" to "Yes"


I hope this can help you.


Best regards,


William Antunes

Hey, thanks for the reply.


I did that already, now I have to wait for another log, if it goes well I will mark your reply as the solution.


Thank you again William :)


Ok, so I am receiveing now the pending e-mails, so I think it's solved.


Thanks to William Antunes :)