Service Studio 11 Crash in windows 10

Good afternoon,


after installing Service Studio 11 from outsystems on a pc with windows 10, whenever you drag an object in the Service Studio 11 project (eg botton), the application crashes and stops working.


Some help ?


Thank you.

Haven't faced the issue. But try running into compatibility mode .

bruno r wrote:

Good afternoon,


after installing Service Studio 11 from outsystems on a pc with windows 10, whenever you drag an object in the Service Studio 11 project (eg botton), the application crashes and stops working.


Some help ?


Thank you.

Did you install the latest version 11.0.113.0 yet?

Me and Bruno R. have the problem on two separate machines.

Both running Windows 10 Pro fully updated.

Searched the web for common solutions and tried what seemed reasonable.

Check Event Logs and got the following:

  1. .NET Runtime Error
    Application: ServiceStudio.exe
    Framework Version: v4.0.30319
    Description: The process was terminated due to an internal error in the .NET Runtime at IP 00007FFA861C3B50 (00007FFA86000000) with exit code 80131506.
  2. Application Error
    Nome da aplicação com falha: ServiceStudio.exe, versão: 11.0.113.0, carimbo de data/hora: 0x5bb65f72
    Nome do módulo com falha: clr.dll, versão: 4.7.3190.0, carimbo de data/hora: 0x5b693b48
    Código de exceção: 0xc0000005
    Desvio de falha: 0x00000000001c3b50
    ID do processo com falha: 0x2b0
    Hora de início da aplicação com falha: 0x01d46c40270c321a
    Caminho da aplicação com falha: C:\Program Files\OutSystems\Development Environment 11.0\Service Studio\ServiceStudio.exe
    Caminho do módulo com falha: C:\Windows\Microsoft.NET\Framework64\v4.0.30319\clr.dll
    ID do Relatório: 404ef2f8-5bb8-4ba5-85a5-936ff8665e21
    Nome completo do pacote com falha:
    ID da aplicação relativa ao pacote com falha:

Tried:

  • Disabling Antivirus and Firewall
  • Updating .NET Framework
  • Updating Graphic Drivers
  • (Edit) Running on Win 7 compatibility mode didn't work

Ran DebugDiag on mini dumps and got not many clues.

Currently running DebugDiag on full dumps.

I also face same issue

I'm also facing the same issue.

I have installed Service Studio 11.6.7.4906 in windows 10 Pro.

When I try to add screen, the studio got hang and I used task manager to forcefully close the Service Studio. I'm facing this issue past 1 week.

Advice to resolve the issue will be helpful and much appreciated,

Please check your environment health from the Service Center>Administration>Environment Health. And check if everything is running and marked as green or not. 

Please check and let me know. Waiting for your response.


Thank you,

Sudip

Hi Sudip,

Actually i'm using outsystems cloud environment and not my personal environment, do I still need to check environment health?

Regards, Gowtham.


Sudip Dey wrote:

Please check your environment health from the Service Center>Administration>Environment Health. And check if everything is running and marked as green or not. 

Please check and let me know. Waiting for your response.


Thank you,

Sudip



yes, It is needed to check. Please check that all "right signs" are green or not. Please let me know

Solution

Gowtham Subramanian wrote:

I'm also facing the same issue.

I have installed Service Studio 11.6.7.4906 in windows 10 Pro.

When I try to add screen, the studio got hang and I used task manager to forcefully close the Service Studio. I'm facing this issue past 1 week.

Advice to resolve the issue will be helpful and much appreciated,

Please Download and  install .Net Framework version 4.8. from below link

https://dotnet.microsoft.com/download/dotnet-framework



Solution

Rupam Ghosh wrote:

Gowtham Subramanian wrote:

I'm also facing the same issue.

I have installed Service Studio 11.6.7.4906 in windows 10 Pro.

When I try to add screen, the studio got hang and I used task manager to forcefully close the Service Studio. I'm facing this issue past 1 week.

Advice to resolve the issue will be helpful and much appreciated,

Please Download and  install .Net Framework version 4.8. from below link

https://dotnet.microsoft.com/download/dotnet-framework


Thank you Rupam Ghosh, installing the .Net Framework 4.8 resolved my issue.


Thank you Sudip for your suggestions.


Please mark the Rupam Ghosh post as a Solution. So it will help other people to get the solution to the same problem,

Thankx,

Sudip