[Multilingual Component] Mobile translations helper app
Forge component by OutSystems R&D

In case you're using the Multilingual Mobile Component for creating multilingual mobile apps, you may find this app helpful: Mobile Translations.

This is a web app that keeping track of translated text resources in you mobile app, exporting/importing the resources to an Excel file to hand out to translators, and export resources to the JSON format required by the multilingual component.

Hi Hugo,

The Excel export file errors when I attempt to open it in Excel. I'm getting the following error...

Removed Part: /xl/sharedStrings.xml part with XML error.  (Strings) Illegal name character. Line 1, column 15988.
Removed Records: Cell information from /xl/worksheets/sheet1.xml part

Excel attempts to fix the problem, but the spreadsheet opens empty. I'm hoping you have solution for this. The JSON export is working fine, but I need to be able to export, edit, and re-import the Excel file.

Thoughts?

Daryl Van Johnson wrote:

Hi Hugo,

The Excel export file errors when I attempt to open it in Excel. I'm getting the following error...

Removed Part: /xl/sharedStrings.xml part with XML error.  (Strings) Illegal name character. Line 1, column 15988.
Removed Records: Cell information from /xl/worksheets/sheet1.xml part

Excel attempts to fix the problem, but the spreadsheet opens empty. I'm hoping you have solution for this. The JSON export is working fine, but I need to be able to export, edit, and re-import the Excel file.

Thoughts?

Hi Daryl,

That's strange. I've just tested this and I'm able to open the generated Excel without any problems.

Which version of Excel are you using?

Hi Hugo,

This issue just recently started. I am able to successfully open other Excel exports, just not one in particular. I'm attaching the file that will not open. 

Version: Microsoft Excel 365, Office 365 ProPlus, Version: 1808 (Build10730.20344)

StericycleHandheld.Translations.xlsx

Hi, I'm getting the same error and there seems to be no special characters in my text. Have you found a solution regarding this?

I'm also encountering this issue, did someone have a fix on this?

Hi Ronillo,

My issue persisted when I removed all the special characters. Then I realized that there were many empty default values. I was able to export after filling all the empty fields. 

ohhh!! I got a lot of those, I'll try to fill out all of the empty fields.. Thank you!

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.