[GraphViz Services] Cannot deploy GraphViz Services from DEVELOPMENT to TEST environments.

[GraphViz Services] Cannot deploy GraphViz Services from DEVELOPMENT to TEST environments.

  
Forge Component
(7)
Published on 14 Nov by OutSystems R&D
7 votes
Published on 14 Nov by OutSystems R&D

Hi,

We have just upgraded our Cloud Enterprise environments to Version 11.0.108.0 and I am trying to install the latest version of GraphViz Services from the Forge and promote it to TEST. 

It installs well from the Forge but when trying to promote to TEST I have the follwing error:

Any idea what is causing this?


Thanks!


Kind regards,

Adrian

Solution

Hello.

I just tried installing the .oap into Service Center 11.0.108.1 and it worked. I don't have an enterprise environment in v11 to replicate the rest of the flow, but I recently had issues with GraphViz in version 10 when installing OutDoc. To fix it I simply opened GraphViz in Service Studio to check the dependencies and updated those also. The same way I'd do with my modules. It worked fine after that manual update. Can you try that instead of directly send from the Forge?


Solution

Yes, opening the module and refreshing dependecies did the trick. but I expect an officially supported component to work out of the box, OutSystems R&D please refresh dependencies and publish a new version.