[Offline Sync Tools]  Error "Must add the uuidv4 script as a required script of your module"

[Offline Sync Tools]  Error "Must add the uuidv4 script as a required script of your module"

  
Forge Component
(2)
Published on 5 Mar by leonardo.fernandes
2 votes
Published on 5 Mar by leonardo.fernandes

Hi Leonardo,

I´m always getting this error when I use the client action from your espace. I already included the javascript "uuidv4" as a dependency, also copy/paste the script for the espace where I´m using the "GenerateGuid" action but always getting the same message.

I'm having this problem on an android device didn't test IOS yet.

what can be the problem?

Thank for your help.

Cheers

Solution

Hi Goncalo,

When you click on the module of a mobile app (where you can change the name of the module, if it's multi tenant...), you also have the option to mark scripts as required. Try and select your UUIDv4 script from the dropdown and publish. Perhaps this requires to generate a new version of the app and to reinstall it.

Please give it a try and let us know if that solved your issue.

Kind regards,

Art

Solution

Thanks Artuur!

It's necessary to add the script as required. Now I can see that this is not documented anywhere in the module. I'll fix that in the next version.


Thanks.