[Google Analytics Plugin] SetUserId doesn't seem to work.

Forge Component
(10)
Published on 2 Oct (14 days ago) by Experts
10 votes
Published on 2 Oct (14 days ago) by Experts

Hi, I set up the User Id feature in my Google Analytics console, however, I don't see any data coming. I call SetUserId method in the layout initialize section, right before I call track screen. Regular data works fine. Can you assist? 

Thanks,

Roman


Hello Roman, 

you continue to face this issue? I use exactly the same action and works for me. 

You have sure that the plugin is available in that mobile device right? 

The only difference in my case is that one, so i encapsulate that action in other that check is the plugin is available. 


Camila 

Camila Teixeira wrote:

Hello Roman, 

you continue to face this issue? I use exactly the same action and works for me. 

You have sure that the plugin is available in that mobile device right? 

The only difference in my case is that one, so i encapsulate that action in other that check is the plugin is available. 


Camila 

Hi Camila, actually it started working after a certain time, I didn't make any changes in my code, so I assume it was a Google Analytics delay or something. Thanks anyway 


Hello.

Did you have a look into this plugin Firebase Analytics or it's not what you pretend? There's in there all those functions you need and it's working properly on my side. I hope it helps!

Best Regards,

Tiago

Hello Tiago, 

I start use the firebase for mobile, because Google Analytics will stop to having maintenance. 

And yes, work good and with more functionalities. 


Thank you, 

Camila