Can not connect to Forge from Service Studio via proxy with authentication

Hello,

I'm using Personal Environment.

After upgrading to Service Studio Release 9 (11.0.204.0) and later, I can not connect to Forge from Service Studio (outsystems tab) via network proxy server which requires authentication.

My proxy setting is correct since I can connect to my environment from Service Studio and can perform 1-click publish.

In previous versions, after opening Service Center in Service Studio by clicking Environment/Module Management button in the toolbar, I could connect to Forge in the outsystems tab. We know that Release 9 and later open Service Studio by the system default browser. Then the trick(?) lost this effectiveness.

Are there any workarounds for the problem?

Best regards,
Moriya Takasi

Hi Takasi,

Sorry for the late reply. Is this still occuring? I'll try to have OutSystems look into it.

Hey Takasi,

Thanks for reporting the problem! Before you also had the problem with Forge and used Service Center as a workaround to login and then go to forge?

Cheers,

Hi Takasi,

Can you check if you still have problems with the most recent version - 11.0.207?

Hello Kilian and João,

Thank you for responding.
I have still this problem with Release 10 (11.0.207.0).

Hello Vasco,

Thank you for comment.

Before you also had the problem with Forge and used Service Center as a workaround to login and then go to forge?

Exactly.
Every time I wanted to connect forge in Service Studio, to open Service Center tab always required.

Today, I noticed that Service Studio 11.0.207.0 occasionally can connect to Forge in outsystems tab.
But I can not find the reproduction procedure.

Hello,

I'm facing a similar proxy related problem, but in my case the Forge tab at Service Studio (version 11.6.13, build 6720) only shows a loader.

I found that occurred the error "(407) Proxy Authentication Required" looking at "general.txt" log file at Service Studio's folder.

But Service Studio was already configured with proxy credentials and I can open Forge URL from IE and Chrome.

Any Idea about how to resolve this?

I wanted to use Forge at Service Studio to check if there are any component in my environment with a new version on Forge.


Thanks!


ps1: Service Studio configuration:

ps2: Error at "general.txt" log file:

Exceptions: [02:41:58.712] System.Net.WebException: The remote server returned an error: (407) Proxy Authentication Required.

   at System.Net.HttpWebRequest.GetResponse()

   at OutSystems.Communication.RESTServices.RESTServiceBase.com#idjyypkb(String x, Uri y, TimeSpan z, String aa, String ab, String ac, IEnumerable`1 ad)

   at OutSystems.Communication.RESTServices.RESTServiceBase.Get(Uri url, TimeSpan timeout, String username, String encryptedPassword, IEnumerable`1 additionalHeaders)

   at prs#ycnlnthh.prs#luyldybb()


Solution

I use Fiddler when I need to connect Forge tab or Native App Builder tab in Service Studio.
https://www.telerik.com/fiddler

Fiddler provides local proxy and can be set information about upstream proxy authentication.
Using Fiddler makes Service Studio free from proxy authentication.

Solution

Hi Takasi Moriya,

It worked for me!

I installed Fiddler and enabled "Rules > Automatically Authenticate".

Thanks!