Camera plugin

Referring to this thread, https://www.outsystems.com/forums/discussion/43555/install-new-application-for-plugin/

I am going through the same thing as Antonellasp using Outsystem Now app. The difference is I can open up the camera app and i can snap a photo but it showed a black blank screen after snapping. When i pressed the back button on my Samsung phone, it went into the "Connecting to app.. " screen and it attempts to "connecting to app..." indefinitely. What could have happened?


1) At the black blank screen, there are two buttons: the smaller black refresh button and a bigger blue-green tick button. Pressing either buttons bring me to "connecting to the app..." screen once again and it got stuck there forever again...



2) Instead of going through OutSystemsNow app, I decided to install the ToDo app directly and I tried to use the camera again. This time around, the photo was snapped and it asked me to Retry or press Ok to continue. After pressing OK, the screen showed "connecting to the app..." and got stuck indefinitely again...


Incidentally, I decided to use an older phone and this time round, it worked flawlessly.

First Phone (not working): Samsung SM-A510FD with Android 7.0 (Kernel version: 3.10.61-12236002; Build: NRD90M.A510FXXU7CRK2).

Second Phone (working): Samsung SM-T705 with Android 6.0.1 (Kernel version: 3.4.39-9117427; Build: MMB29K.T705XXU1CPI4)


Both are Samsung devices (original, no root). Both using default camera app (i tried other camera app on First phone and unable to get it to work). Is OutSystemsNow app incompatible with Android 7.0?


How can I get the camera plugin to work?

Hi Christopher,


Are you testing this out just to look at the samples or are you trying to create something? I am asking just to understand what you are trying to accomplish with OutSystems now versus creating your own mobile app. In general, OutSystemsNow is primarily around for testing - but since the platform let's you very easily create your own mobile app - it should be fine either way. Your 2nd scenario sounds like you are using the OutSystemsNow application as well.  Can you give me any information about the version of the platform that you are using? What specifically are you trying to do with the camera? That will help me point you in the correct direction.


Thanks


Stacey

Hi Stacey

Thank you for getting back to me.

I found out the reason why the camera did not work was because of a particular setting (Do not keep activities) enabled in Developer Options. When i disabled it, it worked well.