[Google Distance Matrix API] Installing version 2.1.0_O11 causes Service Studio to crash

Forge Component
(4)
Published on 2018-11-02 by Hanno
4 votes
Published on 2018-11-02 by Hanno

Hi!

I was trying to install version 2.1.0_O11 from within Service Studio 11.0.406.0 but this causes Service Studio to crash.

Tried this within different environments (11.0.118.0, and 11.0.211.0) and the same errors happens. So, it does not seem to be related with the environments.

Tried using Service Studio BETA 11.0.407.101 and same error happens.

I have reported this error to OutSystems.

Does anyone else also experiences this error?

--Tiago Bernardo

Found out what was one problem:

Because the previous version was an OML instead of an OAP, I previously created manually an application (type Web) named "Google Distance Matrix API" and placed the espace "GoogleDistanceMatrixAPI" in that application.

When trying to install the new application OAP for version 2.1.0, trough Service Center (not Service Studio) I got this more helpful error :

So I just renamed the application to another name, but kept the espace "GoogleDistanceMatrixAPI" in that application.

Note that the application, although renamed to a different name than "Google Distance Matrix API", still had at this time the type of application Web.

I tried again using Service Studio (not Service Center) to publish the new version from the Forge, but still Service Studio crashed giving no clue on what happened.

I went back to Service Center (not Service Studio), tried to publish the application, and it worked!

It was then that I noticed that the espace "GoogleDistanceMatrixAPI" is now a Service! And the application "Google Distance Matrix API" is now a of type Service (not Web).

1) Before publishing version 2.1.0_OS11.

2) After publishing version 2.1.0_OS11.

It is my bad that I did not read carefully "What's new" of version 2.1.0, 

But I was not expecting it to be "Converted to Service Module"...

Conclusion:

When publishing a new version of a component from the Forge, pay close attention if it has been converted to Service Actions!

Note:

Although in version 2.1.0 the espace and application have been converted to Service, still it only provides Server Actions.

--Tiago Bernardo