[Pivot Table] Cant read date format

Forge Component
(8)
Published on 2017-10-05 by Gonçalo Borrêga
8 votes
Published on 2017-10-05 by Gonçalo Borrêga

Hello,


I've been using this component in my program and it works fine so far. The only problem is that it cannot read date formats so date column will always be null value. I used the PivotTable_FromTable web block . Is there any way to fix this? 


Thank you,

Syafiq

Solution

Hi Muhammad,

Double check that you don’t have any container wrapping the date expression in your table and that you’re not formatting the expression with a function on the screen (eg datetime_prettyformat(YOURDATE)). The date needs to be there in raw.


If after checking this it still doesn’t work, let us know your server date format (check it in Service Center)


Best

GB

Solution

Hi Gonçalo,

Thank you for the reply. I already removed the formatting on the table and it still doesn't show. The date format on the service center is YYYY-MM-DD.

UPDATE :

- After another check, I found out that the dates was still inside a container just like you said. Thank you for the response It helped a lot :)

Regards,

Syafiq