The INSERT/UPDATE/DELETE permission was denied on the object (SSMS)

I'm running OutSystems in the cloud, and I have SQL Server Management Studio (SSMS) connected to our cloud databases.

When I deploy from TEST to PRODUCTION, the database table scripts are run which creates the new tables in the Cloud Database.

But ... when using SSMS to modify any of my user databases, I get the following error whenever I run any scripts to insert/update/delete on the newly created tables.

The INSERT/UPDATE/DELETE permission was denied on the object

But if I want about an HOUR, then the error disappears. It appears that some background process must eventually update the cloud production database and grant the necessary SQL permissions. 

Is there anyway I can speed up this process?
e.g. if I want to run several migration scripts soon after deployment. Is there some system timer that I can run to hurry up this permissions assignment?


Yes I know I could write it inside service studio, and deploy it "when published". But since I have SSMS connected to our cloud database I would like to use this where possible.

Any ideas? Or any recommendations for how to run scripts after deployment?

Hey Alan,

Have you tried putting in a support ticket about this?  OutSystems might want to look at how your environment is setup in order to answer this.

OK. I have created a support ticket now.