[HealthPlugin] Not be able to access the data

Forge Component
(3)
Published on 18 Jul by Sofia Mourato
3 votes
Published on 18 Jul by Sofia Mourato

Hi,

I have install healthPluginDemo but it is not giving me any data.

 It also not opening the permissions when i clicked on Request Authorization. 

I have enabled the health kit for my app and i am generating the app with the health kit enables provisional profile.

Kindly can you please help me.


Hi Mohammad,

Are you using iOS or Android?
We have released a new version of the HealthPlugin yesterday, with a fix for iOS devices.

Kind regards,
Sofia

Hi Sofia,

I am using it in IOS. Os version is : 12.1.4

Regards,

Mohammad Hasib wrote:

Hi Sofia,

I am using it in IOS. Os version is : 12.1.4

Regards,

Hi Sofia,

It is working for android. I checked it now.

Regards,

Hi Mohammad,

Did you try to download the latest version of the HealthPlugin component (v 2.0.1)?

Kind regards,
Sofia

Hi Sofia,

Yes downloaded the latest version and regenerate the app.

But still it is not working for me. I installed for Outsystems 10 .

Regards,

Hi Sofia,

I think the problem is IOS version. You need to test your app in IOS 12.1.4 which is the latest update from apple.

Regards.

Hi Mohammad,

I've just tested in an iPhone with iOS 12.1.4 and it worked well.
Do you want to send me your OML so I can test and try to help you with the issue you're having?

Kind regards,
Sofia

Hi Sofia,

I am using the same sample OML file which you have provided on forge.

I am attaching the same file. If you want me to send my .ipa file then i can send you that also. But for installation you need to provide me the udid for your phone. OR you can share your generated .ipa file so that i can test in my phones.

Regards,

Dear Sofia,

It is not working for outsystems 10 application.

It is working fine Outsystems 11.

Can you please provide the same update for the outsystems 10 environment.

Regards,

Solution

Hi Mohammed,

I'm wondering why would you want to have it on the OutSystems 10 if you have an OutSystems 11 version?
I currently don't have a way to release the plugin with the OutSystems 10 version.
What you can try to do instead, is to compare both versions and apply the necessary changes on the plugin installed on the 10th version.

Kind regards,
Sofia Mourato

Solution

Thanks Sofia,

I have already done this exercise and it is working fine for me.

The question why i needed for outsystems 10 because we have the outsystem 10 server only. We can not upgrade it from 10 to 11 right now.

Thanks a lot for your co operation.

Regards,