80
Views
1
Comments
[Azure AD Mobile Plugin] azure AD Mobile Plugin: retrive data but can't log in.
Forge component by Pedro Costa
7
Published on 16 Jan 2019

Hi,

I'm trying to use Active directory to log into a mobile application, but apparently it get's the data right but still can't log in, here's the steps I followed:


I created the application as the steps here, but I'm not sure of the replying url I used, I tried tentantname/applicationname, or myoutsystemenviroment.com/myapp name, so I'm not sure what to use here.

https://github.com/Azure-Samples/active-directory-dotnet-native-multitarget#step-4--register-the-sample-with-your-azure-active-directory-tenant


Second thing I configured the application as shown here:



Do logIn as following:


I even add this in the site property of the AD application:



I'm generating the application when testing it and regenerating it again if any changes happen, is there any further solution or configuration I should do. Thanks a lot.



Hi Abeer,

I haven't tried using this component but may I kindly suggest to take a look on the IdP mobile component as well.

And also try to check if this will also be useful to you.

https://success.outsystems.com/Documentation/11/Developing_an_Application/Secure_the_Application/End_User_Management/End_Users_Authentication/Configure_Azure_AD_Authentication

Thank you and kind regards,

Chris